Jump to content
artjourney

Designer crashes upon entering "Properties" for Vector Layer

Recommended Posts

Not sure if this has been reported before, but this is something I just found out today while exploring vector layer. Upon creating a vector layer, I right click to go to "Properties" so I can change layer color etc... but it always crashes.

Currently using 1.6.1

Share this post


Link to post
Share on other sites

I'm a bit confused, @artjourney.

Perhaps the Mac versions are different from the Windows version of the Affinity applications, but right-clicking on a vector object does not give a menu with "Properties" as one of the choices. Neither does right-clicking on its layer in the Layer panel.

So I'm not sure what you're clicking on (or trying to click on) in that menu.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

Thanks. I had forgotten about that right-click option. It's only there for a (Layer) kind of layer. Note, for terminology purposes, that your Layer1 is not a "vector layer". It is simply a Layer (capital L), which is a container for other objects.

I don't recall anyone reporting a problem accessing the Layer Properties, but someone else will know. Thanks for reporting it.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

Hi @artjourney,

I could not replicate this carsh.

Can you please try this?

Close Designer . Open Finder. Go > Go to Folder >  ~/Library/Containers/com.seriflabs.affinitydesigner/Data/Library/Application Support/ and rename user to user.backup. Reopen Designer.

Thanks,

Gabe. 

Share this post


Link to post
Share on other sites

That was a strange hiccup. Apparently, removing the entire folder didn't help. But restarting the computer did. Problem solved after restarting the computer.

EDIT: But then it crashes again after a short while doing something else on my computer. Hmm... I might have to put in the time later to find out what is causing it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.