Jump to content
GeoffM33

Lens correction profile mismatch

Recommended Posts

I am using a Nikon D5600 with Nikon kit lenses 18-55, and 55-200. In Develop Persona/lens the correct lens correction profile is shown for the 18-55, but for the 55-200 it shows as a Sigma model 55-200. I checked the list of lens correction profiles in this forum (Patrick Connor Dec 2018) and found both my Nikon lenses listed, and a Sigma one of similar spec:

Nikon AF-S DX Zoom-Nikkor 18-55mm f/3.5-5.6G ED
Nikon AF-S DX Zoom-Nikkor 55-200mm f/4-5.6G ED

[wrong one]: 

Sigma 55-200mm f/4-5.6 DC

Can I get Photo to see the correct profile somehow, or is this a bug?

GM

Share this post


Link to post
Share on other sites

You might try the 1.7 beta of Photo (current Mac download available in this post) and see if it behaves better for you. They rewrote the processing for gathering the EXIF information, which might affect that aspect of the processing.


-- Walt

Windows 10 Home, version 1809, 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.6.5.123 and 1.7.0.331 Beta       / Affinity Designer 1.6..5.123 and 1.7.0.331 Beta    / Affinity Publisher 1.7.0.330 Beta

Share this post


Link to post
Share on other sites

Sorry, I should have mentioned that this query came up whilst using the 1.7 Beta. I checked that I am using the latest patch.

After Walt's comment, I went back to my paid-for 1.6.7 AF Photo to check how that worked. In both iterations the lens name is correctly reported in the info strip along the top of the working window. In both versions lens correction can be switched on in the Assistant options; in 1.6.7 you can't tell what it is doing except for the change in the image if you can spot it.

In 1.7 beta you can manually switch on the lens profile in the lens tab in the righthand develop studio panel. There is a drop-down. With my 18-55 "normal" lens this drop-down matches the spec in the main window header, but with the 55-200 the drop-down reports a Sigma 55-200 profile whilst the main window header shows the correct Nikon 55-200 name. When clicking the profile on-or-off you can see the image shape pop in and out. So I don't know if this is a good result or not.

I must go and photograph a brick wall with both lenses and check against the grid overlay in the app. ;-)

Share this post


Link to post
Share on other sites

Thanks. Here is a file taken recently with Nikon D5600 and Nikon 55-200 lens which shows a Sigma lens name in the "lens" tab in the develop persona Right-hand Studio sidebar. Lens description in the strip along the top of the main window is correct.

G.

_DSC0544.NEF

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×