Jump to content
RebDovid

Affinity Beta Doesn't See RW2 Images From LX100M2

Recommended Posts

My current workflow with images from my Panasonic LX100M2 involves culling in FastRawViewer, developing in SilkyPix Developer Studio 8 SE, and, when it seems necessary or desirable, doing additional editing in Affinity Photo Beta (with the latest build, now 1.7.0293). My computer is running Windows 10.

After using FRV to select a raw image to develop and edit, I have FRV pass it on to SilkyPix. Once developed in SilkyPix, and if I think it needs further work, I save/export the image as a tif and work on it in Affinity. (The free Panasonic-only version of SilkyPix doesn't allow for opening an image directly in another program.)

Inconveniently, however, neither the beta nor regular versions of Affinity Photo see the RW2 images. Instead, when using File/Open, the program sees an icon that says "RW2" and shows the shot number, e.g., P1000321.RW2. Fortunately, double-clicking on the icon opens the image in both Affinity Photo and Affinity Photo Beta.

Although this problem doesn't prevent me from using Affinity, if there's an existing solution I'd like to know what it is.

TIA

 

 

Share this post


Link to post
Share on other sites

You would like to see thumbnail of raw format?

I think it was said before AP will show you exactly what your windows version sees, no internal raw thumbnail viewer - internal Windows stuff only.

As you, I also can't see Panasonic thumbnails as my Win10 doesn't know anything about it but I see DNG thumbnails from Pentax but no DNG from Huawei, no CR3, no ARW...

 

If you need to see them and lot more and send to edit from viewer may I suggest you a Fast Stone Viewer - great free software

 

Share this post


Link to post
Share on other sites
5 hours ago, RebDovid said:

if there's an existing solution I'd like to know what it is.

You may need to install a codec pack for Windows, such as FastPictureViewer codec pack. Google or other search engine may reveal others.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.