Jump to content
chris_001

Slow Performance / Nadir Retouching

Recommended Posts

Hello,

i've just downloaded the Demo Version due to recommendations. Mainly I'll want to use it to retouch the nadir on high resolution HDRI Spheres (35 k). And that's the problem: Affinity can't handle that resolution on my PC (it seems so!) but other photographers told me it runs smoothly on their workstation.

- The infill-tool lasts ages to fill something. Even in small areas.

- The Clone-Tool lags totally. It has no acceptable functionality.  

I've built in 64GB Ram and a Xeon 2145 with 3.7 GHz Base Clock and a RTX 2080Ti. Affinity is also installed on a SSD. So there shouldn't be any issues?

Do you have any workaround or suggestions how to improve the performance?

Many Thanks, Chris

Share this post


Link to post
Share on other sites

Hi Chris_001,

Welcome to the forums :)

If possible could you make the app perform badly and tell me what the CPU usage is in task manager?

Thanks

Callum

Share this post


Link to post
Share on other sites

Hi Callum,

unfortunately my Test Periode expired these hours. If you promise me, we'll solve the problem, i'll buy a license right now! :D

 

Share this post


Link to post
Share on other sites

Hi Chris, it sounds like your issues will be vastly improved by version 1.7 when it's released.

It has a number of threading/general performance improvements that dramatically speed things up for high-end processors—I think your Xeon is an 8-core/16-thread? I've just tried editing a 16k HDRI using live projection, inpainting and cloning and it runs really well (this is on an i7 4-core/8-thread). With a 35k HDRI in version 1.7 I would now expect good performance with your Xeon.

You can actually download and use the 1.7 public beta (stickied thread at the top of https://forum.affinity.serif.com/index.php?/forum/34-photo-beta-on-windows/) but it requires a valid license key to be activated, meaning the software needs to be purchased.

There are two potential options: you could wait until 1.7 is released, download the trial and see if performance is improved for you. Alternatively, if you were eager to try it now, you could purchase 1.6, then download and install the 1.7 beta (it sits alongside the current release build and does not interfere). If you aren't satisfied, you could then request a refund citing performance issues—it's a 14-day return window if you purchase through the Affinity store (see https://store.serif.com/en-gb/help/). If you purchased through the Microsoft Store you would have to request a refund through their system instead.

Apologies, as I realise there is no immediate solution for version 1.6—although you could tweak the performance options, they are unlikely to produce any significant improvements. 1.7 should present a huge leap in performance for the majority of higher-end PCs like yours.

Hope that helps!


Affinity Photo Video Tutorials - Affinity Photo for iPad Tutorials

Looking for a manual/documentation? Check affinity.help for online help!

@JamesR_Affinity for tutorial sneak peeks and more

Share this post


Link to post
Share on other sites
Posted (edited)

Hi James, thanks also for your fast response. Great support!

I've just purchased affinity photo and installed the beta. And yes, it's much more faster! Especially the clone tool works like expected! Also selecting (!) the tripod with the freehand tool is really good and the filling is also felt 50-times faster. Please improve it as much as you can! There's no software (as far as I know) which can manage this issue.

Nevertheless there are two further questions:

First, I'm wondering how to add a second HDRI Layer to my Composition. Right away, Version 1.6 crashes if I try it.

For Example: I've a Backgroundlayer. It's the whole 360° HDRI. And I've a second Layer. That contains only the sun. So, if I retouched the Backgroundlayer and import/place the Sun-Layer -  nothing happens. If i drag + drop the sun Layer into the composition, nothing happens too. As said, if I try it in 1.6 I get an error message. Do you have a idea?

And: 

Second, I like to balance the HDRI into affinity. Are there any plans to integrate a divide blende mode?

Thanks again!

Edit: Ok, it seems so that 1.7 crashes too. I have waited about 20 Minutes but nothing happened. But everything freezed. 

Edited by chris_001

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×