Jump to content
davide445

[3rd Party Issue] Filter Forge 8 exception in Photo

Recommended Posts

Tested today since I'm evaluating FF 8 to be used with AP, and with any kind of selection in the photo if I try to open FF give me an exception

<class XFW::ArgumentError> Unexpected mask presence state.

FF is shown with Unknown status in the Plugins and I allow "Unknown" plugins to be used.

In this FF thread the moderator state

Quote

Filter Forge worked perfectly in Affinity 1.5. Starting with version 1.6, Serif broke their plugin support while we didn't change anything in the plugin. Feel free to nag Serif about fixing what they broke.

This was in December 2018, it's expected something is happening, or FF will remain in the limbo since neither FF nor Serif are working to find a solution?

This happens both in stable 1.6 than in beta 1.7.0.293.


Windows 10 Pro, KDE Neon, Ryzen 5 2600X, 32GB DDR4@3200Mhz, Kfa2 GTX 1070 EX 8GB + Sapphire HD 7950 Dual-X w Boost 3GB, 2560x1080 HDR ultra-wide, HTC Vive Cosmos VR

Affinity Photo, Affinity Publisher, PagePlus, ShaderMap Pro, Substance Designer, Davinci Resolve, HitFilm Pro, Unreal Studio, Unigine, BricsCAD, 3ds Max, Houdini, 3D-Coat.

Share this post


Link to post
Share on other sites

Filter Forge:

"AND while our developers try to solve this official support problem with Serif, there's one nice and simple workaround: copy and paste to use FF and AP together." 

"Filterforge 6 isn't working anymore. In the latest 1.5 it works fine..." 

Not my job to check but the post in the beta section is referring to FF 6, we are in the 8 version, the other post state you are working together to solve the problem, are you? Since appear nobody is doing anything... 


Windows 10 Pro, KDE Neon, Ryzen 5 2600X, 32GB DDR4@3200Mhz, Kfa2 GTX 1070 EX 8GB + Sapphire HD 7950 Dual-X w Boost 3GB, 2560x1080 HDR ultra-wide, HTC Vive Cosmos VR

Affinity Photo, Affinity Publisher, PagePlus, ShaderMap Pro, Substance Designer, Davinci Resolve, HitFilm Pro, Unreal Studio, Unigine, BricsCAD, 3ds Max, Houdini, 3D-Coat.

Share this post


Link to post
Share on other sites

So this topic can't be in the (Resolved) subforum I suppose, or need to be merged with other tracking.


Windows 10 Pro, KDE Neon, Ryzen 5 2600X, 32GB DDR4@3200Mhz, Kfa2 GTX 1070 EX 8GB + Sapphire HD 7950 Dual-X w Boost 3GB, 2560x1080 HDR ultra-wide, HTC Vive Cosmos VR

Affinity Photo, Affinity Publisher, PagePlus, ShaderMap Pro, Substance Designer, Davinci Resolve, HitFilm Pro, Unreal Studio, Unigine, BricsCAD, 3ds Max, Houdini, 3D-Coat.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.