Jump to content

Affinity Photo Crashing when trying to open any file

Recommended Posts

Posted (edited)

Affinity Photo has been working great up until now. I launched AP and it opens just fine but as soon as I try to open a file, new or recent, it immediately crashes. I've restarted my MacBook Pro: Didn't help. I reinstalled AP: Didn't work either. I attached a image of part of the crash report. Hopefully somebody can understand it as I don't. Thanks for any help.

Additional information. The first thing I tried to do before the first crash was to open a jpeg. I went an unusual route. Affinity Photo was already open with no files opened. I first opened a file with Preview because I just wanted to quickly view it first. When you open a file with Preview there is a small jpeg icon beside the file name at the top of the window. I sometimes drag that icon into Affinity Photo if I decide I want to use it. When you drag the icon over top of AP you get a little green circle with a plus sign in the middle indicating AP should accept the file which has always worked for me in the past. This saves me the time of going to File>Open... and then re-searching for the image if I decide I want to use the photo I am previewing. I don't always go this route but occasionally I will. This has always worked without a problem before but when I tried it this time, Affinity Photo immediately crashed. I tried to open the same file going to AP File>Open>selected my image, but as soon as I click open, AP crashes immediately again. I tried going to File>Open Recent... and opening any previous file but they all cause AP to crash immediately. I even went to the file first, Right Clicked and chose Open With AP, it then crashed immediately. Nothing seems to work, any file I try to open crashes AP making it totally useless until somebody can save me. I hope this info helps. Thank you.

Screen Shot 2019-04-13 at 12.15.45 AM.png

Edited by wrc04

Share this post

Link to post
Share on other sites

Hi @wrc04,

Welcome to the forums. 

Try to reset the app first. 

You can reset your app back to its default settings by holding down the CTRL key while launching the app. When the Clear User Data window appears, click Select All and then Clear. The app will now open.
Be aware that resetting your app back to its default settings will lose any custom settings such as keyboard shortcuts and brushes etc. To backup such settings before resetting the app, please watch our Affinity - Exporting User Settings and Keyboard Shortcuts video.

Share this post

Link to post
Share on other sites

That did the trick. Thank you so much Gabe! Do you have any idea how this might have happened so that I may avoid making the same mistake in the future or is this just one of those hiccups that can happen for a various of reasons? Thanks again, I appreciate the response. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.