Jump to content

Recommended Posts

Posted (edited)

Large panorama, trying to inpaint a relatively small missing section, I can semi-reliably (not every time but many times) get the app to (what looks like) loop allocating memory. The two times I tried to repro this in the beta the inpaint succeeded (different images) but this seems serious enough to offer up in case you want to verify.

Affinity Photo 1.6.11

The project file is 6+GB so I'll wait for you to ask for it. :-D 

As a side note, this was another instance of the behavior that inspired this feature request:

 

Screen Shot 2019-04-08 at 8.34.57 PM.png

Screen Shot 2019-04-08 at 8.35.05 PM.png

Screen Shot 2019-04-08 at 8.39.46 PM.png

Edited by Brad Brighton
Added a link to the feature request post inspired by this behavior

https://bmb.photos Focus: The unexpected, the abstract, the extreme, including paper outputTools: macOS (Primary: Mojave, MBP2018), Canon (Primary: 5D3), iPhone (Primary: X), Epson

Share this post


Link to post
Share on other sites
Posted (edited)

Hi @GabrielM,

I noted in the original post that I have already tried this on the beta (more info: on version 1.7.0.116) and have not yet gotten it to fail. Unfortunately, this does not seem definitive since the operation doesn't fail every time on 1.6.11 either. This has happened with two different images (both large panoramas) but after I force-quit the app and go back in, I _seem_ to be able to inpaint on the next round.

If there's a consistent repro case, I haven't identified it yet. :-( 

Edit: It has happened again with the same image on 1.6.11. On the beta, it still has not hung but it does chew memory, 3-5GB (seems expected given the size of the image). Also on the beta, the result is not what I would expect -- an incomplete inpaint. (see the screenshot of the beta result) While I've been testing, I've been trying to keep the highlighted area similar as much as possible in both versions so that the production apples and beta oranges aren't too far apart.

Screen Shot 2019-04-09 at 10.29.45 AM.png

Edited by Brad Brighton
Additional information on the behavior of 1.7.0.116 photo vs 1.6.11 photo

https://bmb.photos Focus: The unexpected, the abstract, the extreme, including paper outputTools: macOS (Primary: Mojave, MBP2018), Canon (Primary: 5D3), iPhone (Primary: X), Epson

Share this post


Link to post
Share on other sites

If the beta is good so far, it's a good sign. We're re-written most of the tools, including the inpainting tool. You might need to have a second pass to fill all the areas. Since this bug does not happen in the Beta, i will close this as Fixed. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×