Jump to content

Recommended Posts

Hi!

I have a weired problem with Affinity Designer...
I'm working on the up-to-date version 1.6.5.135 under Windows 10. 

I have a couple of icons, that I created some while ago (I believe before updating to .135). These icons are saved as .svg and I need them to be pure vectors without rasterized pixel-portions, because MS Visual studio is supposed to find and recolor the hex-color values.
I've been careful not to use any effects that were incompatible with SVG (no transparency, no masks etc.)

 

I attach the SVG, I exported some time ago which has been exported without a problem. Opening the .affinitydesigner file also exports without a problem.
However - when I re-open the exported SVG and try to save (via export to svg) it (not having touched and altered anything) Designer wants to rasterize certain parts, rendereing the file unusable for me.

Is there something, I'm not getting?

new export.svg

old export.svg

original.afdesign

Share this post


Link to post
Share on other sites

Always use the "more" button in the export panel to make sure the rasterize settings is the one you want.
Don't assume the settings are the same when doing a new export.
test.svg was exported from AFdesigner beta 1.7.0.284
Opened test.svg in the retail version 1.6.5.135 and exported to test2.svg
 

test.svg

test2.svg


-------------------------------------------------------------------------------------------------------------------------------
Win10(1809)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×