Jump to content
MattP

Affinity Designer Customer Beta (1.7.0.9)

Recommended Posts

Status: Beta

Purpose: Features, Improvements, Fixes

Requirements: Purchased Affinity Designer

Mac App Store: Not submitted

Download: Here

 

Hello,

We are pleased to announce the immediate availability of the beta of Affinity Designer 1.7 for macOS.

Designer 1.7 is a significant change to the currently shipping 1.6 version. Files edited in this version will not be backwards-compatible with the shipping 1.6 version. As such, we would not recommend using this 1.7 version for critical or production work at this stage. It is inevitable that there were will be a number of issues with 1.7 but we hope these will be minor and aim to resolve any issues very quickly, so please use it and explore the new features, but also do keep in mind that you may find snags and we would appreciate your help with finding and reporting these to us.

If this is your first time using a customer beta of an Affinity app, it’s worth noting that the beta will install as a separate app - alongside your store version. They will not interfere with each other at all and you can continue to use the store version for critical work without worry.

It’s also worth noting that we aren’t done yet - we are still working through reported bugs from previous releases and hope to fix as many as possible before the final release of 1.7.

With all that said, we hope that you will enjoy the new capabilities introduced in this initial release and we look forward to any and all feedback you give to us.

Many thanks,

Matt

 

Please refer to previous beta updates for a full list of all changes to date. This latest update builds on the 1.7.0.8 changes and also includes the following changes:

  • Fix for incorrect view background when drawing with Clip to Canvas turned off
  • Live readout of node positions from the Node Tool in the Transform panel
  • Colour picker now available (as it used to be in 1.6!) from the Shape, Gradient Fill, Vector Pencil and Vector Brush tools by holding Alt/Option before the drag
  • Colour fill button now available on the context toolbar of the Gradient tool when a single stop is selected
  • Fix for Lock Children acting erratically for containers that had masks and clips
  • Fix for embedded documents causing hangs
  • Isometric creation tweaks (create-in-plane now works with create-along-axis and create-about-centre)
  • Added a method to help select artboards if you start your drag outside the artboard.

Share this post


Link to post
Share on other sites

I'm having a strange issue where I can't select objects with the marquee selection within an artboard. Not sure what's going on.

602438974_ScreenShot2019-04-04at8_52_29AM.thumb.png.824a6f6b3a7622a4a0509999fba1cced.png

Share this post


Link to post
Share on other sites
Just now, HYR said:

I'm having a strange issue where I can't select objects with the marquee selection within an artboard. Not sure what's going on.

602438974_ScreenShot2019-04-04at8_52_29AM.thumb.png.824a6f6b3a7622a4a0509999fba1cced.png

This sounds like it's falling foul of the new code to help select artboards... I'll ask Ben to look at this straightaway... thanks! :)

Share this post


Link to post
Share on other sites
On 4/4/2019 at 10:08 AM, MattP said:

Colour fill button now available on the context toolbar of the Gradient tool when a single stop is selected

I was a little confused about this one, so I had to experiment it. I think I understand now. The fill of each stop (shade) is displayed in the colour fill button as oppose to the entire gradient. Okay, I get it. And pressing the Esc key once resets the fill to the overall gradient. I like that change.


The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Share this post


Link to post
Share on other sites
On 4/5/2019 at 1:55 AM, HYR said:

I'm having a strange issue where I can't select objects with the marquee selection within an artboard. Not sure what's going on.

602438974_ScreenShot2019-04-04at8_52_29AM.thumb.png.824a6f6b3a7622a4a0509999fba1cced.png

 

@HYR,

I have tested this.  I found out that if you drag the marquee from outside the artboard, then it doesn't sect the inner contents of the artboard.  However, if you drag the marquee within the boundaries of the artboard, you can successfully select the inner contents without any issue.

I hope that helps.

Nana

Share this post


Link to post
Share on other sites

image.thumb.png.c66b498e8b75a17239f28e6454deaafb.png

Hey guys, I'm noticing an issue, or maybe it's just a misunderstanding, with the setup shown in this image, whenever I try to adjust the margins, they always turn back to 0px. Is there something I'm missing? I'm trying to get the filled guides to start at 16px from either side on the left and right.

Share this post


Link to post
Share on other sites
On 4/7/2019 at 6:39 AM, Nana said:

I have tested this.  I found out that if you drag the marquee from outside the artboard, then it doesn't sect the inner contents of the artboard.  However, if you drag the marquee within the boundaries of the artboard, you can successfully select the inner contents without any issue.

On top of that, I found that this is the case for custom artboards only. I press the delete key while the Artboard Tool is selected to keep the new canvas size and keep the objects inside. Then if you drag the marquee from outside the artboard, you should be able to select the objects inside.


The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Share this post


Link to post
Share on other sites
On 4/4/2019 at 4:57 PM, MattP said:

This sounds like it's falling foul of the new code to help select artboards... I'll ask Ben to look at this straightaway... thanks! :)

Hope this will be fixed, most loved and used feature by me.

Share this post


Link to post
Share on other sites
On 4/8/2019 at 12:51 PM, GeneralAce55 said:

image.thumb.png.c66b498e8b75a17239f28e6454deaafb.png

Hey guys, I'm noticing an issue, or maybe it's just a misunderstanding, with the setup shown in this image, whenever I try to adjust the margins, they always turn back to 0px. Is there something I'm missing? I'm trying to get the filled guides to start at 16px from either side on the left and right.

Ah! I've just realised what's going on! It works if you don't have an artboard, but the moment there's an artboard it won't allow you to modify the margin - I'll get that looked at, thank you! :)

Share this post


Link to post
Share on other sites

Hi Matt, I don't know if it's a bug, but it can't hurt to bring it up. When I have a shape selected and then have the "Insert behind the selection" button enabled, using the Pencil or Brush Tool to start drawing from behind the shape and work my way out, the stroke does not work in real time (if that's the right term). In other words, the Pencil Tool and Brush Tool do not leave a stroke as I draw. The stroke appears after release. I tested the the other two buttons, and the Pencil and Brush Tool do work in real time. It's just that first button that results to that issue.


The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Share this post


Link to post
Share on other sites

Hey there, 

this is still an issue.

I've been trying to use the new features, since AE finally updated to 1.7 .

As a webdesigner, i obviously use artboards AND margins/column guides.. etc 

So my question is, is it still a known issue to be fixed in the near future? 

Thx


Webdesigner at Tribu And Co | French web agency - See our work at http://www.tribu-and-co.fr

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.