Jump to content
vjsouza

[Fixed] AD/AP 1.7.0.284 freeze at File/Place...

Recommended Posts

Hello, guys at Serif.

Affinity Photo and Affinity Designer 1.7.0.284 freezes at file/place.

No mater if source file is RGB or CMYK. Both programs simply stop to work after I do File / Place.

What I ask here, and what many people have already asked for, for God's sake, add the File / Link function ...
So, if I update the linked source file, it will automatically update the file that contains the link.


To reproduce the BUG again

1. Start Affinity Photo Beta 1.7.0.284 or Designer Beta 1.7.0.284.
2. Create any document with anything and save it.

3. Close the program and open it again
4. Create a new document
5. Do File / Place...

Please Serif people, I'd really like you to fix the bugs without ruining what's working well.

To be placed.afdesign

To be placed.afphoto

To be placed rgb.afdesign

Share this post


Link to post
Share on other sites

Using my own files in Photo I did not get a crash

Let me throw this out ...

They have a bunch of bugs related to the screen resolution being larger than 100%% Tou might want to check that for no other reason than to rule it out

 


Affinity Designer 1.7.0.367 & beta 1.7.0.390 Affinity Photo 1.7.0.367 beta  1.7.0.390 Affinity Publisher 1.7.0.399

Windows 10 Pro 64-bit 1709

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Share this post


Link to post
Share on other sites

Okay... a little more to go on. Yes, AD284 does indeed freeze when placing a .afdesign file... BUT... Place works okay on .jpg and .png file. So, I suppose, Export .jpg/.png and then Place?? APub283 does not freeze on Place .afdesign file.

Share this post


Link to post
Share on other sites

Mark Ingram, if I do Replace Document for a selected object named "(Embedded document)", AD & AP freezes too!

Share this post


Link to post
Share on other sites

Thanks for your help with this bug. We have now resolved the problem and will make the fix available in the next Windows release.


SerifLabs team - Affinity Developer
  • Software engineer  -  Photographer  -  Guitarist  -  Philosopher
  • iMac 27" Retina 5K (Late 2015), 4.0GHz i7, AMD Radeon R9 M395
  • MacBook (Early 2015), 1.3GHz Core M, Intel HD 5300
  • iPad Pro 10.5", 256GB

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×