Jump to content
EvanDa

Affinity Photo Beta 1.7 Windows Version Not Supported Error

Recommended Posts

I've just installed the most recent Affinity Photo 1.7 Beta (Downloaded March22, 2019) on my Windows 10 machine, and it says "setup cannot proceed for the following reason: Supported Windows Version Not Found". I'm on a stable amd fx 8320 8 core machine with 16 gigs of ram, using a version of Windows 10 updated to the 2017 spring service pack. I have checked dxdiag and I'm using direct x version 11.2. What else is needed to make this installer run? Current Affinity Photo version 1.65 runs just fine and is perfectly stable. I'd really prefer NOT  to update to the latest Windows 10 service package due to the huge instability problem with Amd Fx processors on this latest update....

Thanks so much for your time and attention!

Share this post


Link to post
Share on other sites

It would help to have your actual Windows version number, not just its name.

In the Release Notes for 1.7.0.258 you'll see this note:

Quote

Fixed crash at startup when only .NET 4.6.2 is installed (due to Microsoft bug - we now require .NET 4.7.2 which prevents installation on Windows 10 1507 and 1511)

Assuming your version is not either of those (which I think are 2015 versions?) then my guess is that your .net level is too low, and the installer doesn't know how to cope with your Windows 10 version from 2017. If that's it, you might grab .NET 4.7.2 from Microsoft's website, using your actual version number, and install it manually.


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.1.404 Beta   / Affinity Designer 1.7.1.404 and 1.7.1.404 Beta  / Affinity Publisher 1.7.1.404

Share this post


Link to post
Share on other sites
52 minutes ago, EvanDa said:

using a version of Windows 10 updated to the 2017 spring

Hi @EvanDa. It sounds like you're on Windows 10 1703 (Creator's Update). Is this the case? That should be a supported version of Windows.

Share this post


Link to post
Share on other sites

Hi, EvanDa,

This is known issue of the installer which Affinity 1.7 now uses(at least we already know it).

Do you know how to set(change) Compatibility Mode on Windows 10 ?

If you're not sure, you'd better search on internet, and you'll find the solution (two ways to set compatibility mode on Windows 10) on Microsoft.

Right Click installer and set compatible mode to Windows 10,  restart Windows , etc...

If you cannot solve this trouble with these solutions, please ask again to Support Staffs of Affinity. They will check their Visual Studio options, maybe...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×