Jump to content

Recommended Posts

hi, i'm having a heck of a problem with designer. recently it's bogging down and gets hung and doesn't respond. right now the dot below the icon is there but i am getting no response. i can't force quit, i've tried, litereally all day. right clicking on the icon, activity monitor, apple icon, nothing. can't re-open either. my mac is older, late 2013 8mb ram, is that my problem? i am using the latest version 1.6.1 on mojave 10.14.3

any help is most appreciated.

jen

Share this post


Link to post
Share on other sites

I think if anything it's more to do with Mojave, I have a 2011 iMac and Affinity runs perfectly fine, I can't update my 2011 to Mojave, well not officially but I've stayed away from Mojave for the moment as people seem to be getting a lot of issues with slowdowns and laggy apps, so I stayed with High Sierra on both systems (I have a 2015 iMac too)

 

I'd generally go to activity monitor if there was a particularly persistent app, but for the majority of times I'd go ⌥⌘⎋ (Alt + Cmd + Esc)

You can try rebooting the system, starting Affinity Designer while holding down 'C' until a reset screen appears.

Other than that it would be an uninstall and reinstall


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad2 iOS 9.35 B|  

Instagram & Flickr - Affinity Designer (ADe) Tutorials - Affinity Photo (APh) Tutorials - Public Domain Images

Share this post


Link to post
Share on other sites

Does Designer show up in Activity Monitor at all?


Affinity Photo 1.6.7 & Affinity Designer 1.6.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.6.11.85 & Affinity Designer 1.6..4.45 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.1.1

Share this post


Link to post
Share on other sites

R C-R is does not show up in activity monitor.

DWright this seems to happen when i am moving quickly through my doc, changing colors and moving items. i'm not doing very complex stuff

firstdefence thanks for the insight. you might be on to something! 

Share this post


Link to post
Share on other sites
10 minutes ago, jasbury said:

R C-R is does not show up in activity monitor.

If Activity Monitor is set to show all processes & it still isn't showing up there, then it isn't running (so there is no need to quit it) even if the Dock shows a dot underneath its icon.


Affinity Photo 1.6.7 & Affinity Designer 1.6.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.6.11.85 & Affinity Designer 1.6..4.45 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.1.1

Share this post


Link to post
Share on other sites
13 minutes ago, R C-R said:

If Activity Monitor is set to show all processes & it still isn't showing up there, then it isn't running (so there is no need to quit it) even if the Dock shows a dot underneath its icon.

hmm.... when i right click on the icon it says force quit and when i try to restart i get a quit the app message first. i tried to uninstall and i a get quit the app message. 

i tried to open designer and it doesn't. 

as a side question, you sound like you know your mac stuff, do you use anything like 'clean my mac'? 

thanks for taking the time to help!

Share this post


Link to post
Share on other sites

the first image is a shot of what i was working on when things went nuts. just clicking thru layers changing colors and moving the flowers. the others are shots of what i am seeing as far as the app not responding and me trying to force quit. dont know if that is of any value or not.

if i can provide any other info, please let me know.

thanks!

 

1595909770_ScreenShot2019-03-20at11_39_48AM.thumb.png.1da19c3188a8251cd356d871cd2ace6c.png

Screen Shot 2019-03-21 at 9.31.28 AM.png

Screen Shot 2019-03-21 at 9.32.01 AM.png

Share this post


Link to post
Share on other sites
17 minutes ago, jasbury said:

as a side question, you sound like you know your mac stuff, do you use anything like 'clean my mac'? 

I do not claim to be an expert on all things Mac but I tend to stay away from third party 'cleaner' utility apps because they have more than once in the past deleted or damaging something they should not have that ended up requiring a reinstall of the OS to fix. This may have been because the utility had not been updated for the current Mac OS version, some pre-existing file system corruption issue, a conflict or incompatibility with another 3rd party add-on, a user error of some sort, or a combination of several of these things. Regardless, for my own use I consider these apps to be too risky & rarely if ever necessary or effective. But as always, YMMV.

 

30 minutes ago, jasbury said:

the others are shots of what i am seeing as far as the app not responding and me trying to force quit.

It seems odd that in the second screenshot the Dock popup shows AD is not responding but in the third one taken ~1 minute later the Force Quit Applications window does not.


Affinity Photo 1.6.7 & Affinity Designer 1.6.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.6.11.85 & Affinity Designer 1.6..4.45 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.1.1

Share this post


Link to post
Share on other sites

attaching the error report, now having the same issue on my MacBook. clearly I am doing something wrong. if anyone can help, I'd be most grateful!

thanks

jen

error report.pdf

Share this post


Link to post
Share on other sites
On 3/21/2019 at 3:22 AM, firstdefence said:

Other than that it would be an uninstall and reinstall

I tried to uninstall but when I try to drag it to the trash it says it can't because it's running. this is getting to be annoying. any other ideas?

Share this post


Link to post
Share on other sites
23 hours ago, DWright said:

Is this happening on a blank document or when you do a specific adjustment

this seems to happen when I am moving through layers, changing colors and moving items. I don't think I'm doing anything complex or that my file is particularly large. I've included screen shots below and an error report from my MacBook because it happened there. I cannot uninstall because when I drag to the trash it says it can't because it's running. I can't reopen either.

Share this post


Link to post
Share on other sites

Almost sounds like its set to Software or OpenGL Basic.

With Affinity running and not doing anything, go to preferences and the Performance tab, take a screenshot of it and upload it here.

The display option should be set to OpenGL or Metal if that is an option, although a lot of people prefer OpenGL.

 


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad2 iOS 9.35 B|  

Instagram & Flickr - Affinity Designer (ADe) Tutorials - Affinity Photo (APh) Tutorials - Public Domain Images

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×