Jump to content
CFou

Static transparent GIF export problem

Recommended Posts

hi,

here is my original png file :

searchButton.png.d5fbca9626b6514dc38a1a41f9b5aeab.png

export with (default values) :

image.png.fdfee8978809e68bf8cc28b1e25fe690.png

Result :

searchButton.gif.c841f4fbe2dec37f07a078fe74cbe18e.gif (orange square in windows explorer view).

What am i doing wrong ?

Thanks :)

Share this post


Link to post
Share on other sites

Try to export: zone, document without background


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

Hi CFou :)

Your image has partial transparency which is not supported in the .GIF (or .PNG 8bit) file format, they only support fully transparent or fully opaque pixels. When exporting as .GIF with a transparent matte, the pixels are overwritten as fully transparent, hence it appears there is nothing in the exported image. I'm a little unsure why Windows Explorer displays this as an orange icon, I'll investigate if this is an OS decision or if we need to change something in Affinity.

In the meantime, if you require this image in the .GIF format then you will need to export it with a white Matte  - this can be set through the 'More' dialogue when exporting. I hope this helps!

Share this post


Link to post
Share on other sites

hi dan :)

thanks, you are right, i forget about that.

anyway, somme pixels are opaque and are saved as transparent, why ? Affinity should take a decision for each pixel : >= 50% opacity = opaque; < 50% = transparent, just like this :

searchButton.gif.08d5624c1259181a2cdb6af5a9bbd39c.gif (3D Paint export lol ).

or may be this can be an option ?

Share this post


Link to post
Share on other sites

No problem :)

4 hours ago, CFou said:

Affinity should take a decision for each pixel : >= 50% opacity = opaque; < 50% = transparent

Currently the decision made when exporting is any pixel below 100% opacity is exported as transparent - I'll log an improvement with our developers to improve this in a future build! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.