Jump to content

Recommended Posts

Whats going on? When i try use gradient with bitmap fill i have got something like this. Why bitmap is not duplicated? is streched....

 

sampl.jpg

Share this post


Link to post
Share on other sites
Guest

Hello mate64, please see my screenshot.

Remplissage bitmap.jpg

Share this post


Link to post
Share on other sites

Change the "Extend:" setting on the Context toolbar to something other than "Repeat" & it should be fine.


Affinity Photo 1.7.1, Affinity Designer 1.7.1, Affinity Publisher 1.7.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.1.143 & Affinity Designer 1.7.1.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.3.1

Share this post


Link to post
Share on other sites
Guest

Select the shape, take the "Fill" tool and "Extend" is displayed in the context bar.

Extend.jpg

Share this post


Link to post
Share on other sites

for the english viewers :)

bitmap.png.54abbea66c40be76f007d6138d4cc3c8.png


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites
Guest

@dutchshader, thanks for the screen in English, moreover I just noticed with this screenshot that the question concerned AP, fortunately that the operation is the same as in AD in this case.

Share this post


Link to post
Share on other sites
2 minutes ago, mate64 said:

I dont have this option... Did i have wrong version of AP?

Have you selected the gradient tool?

Can you give us a screenshot of your complete Affinity Photo window, with the gradient tool selected?


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

Do you have type set to bitmap, in your screenshot it is set to none


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites
Guest

Considering the screenshot you posted you must have it.
To make it visible in the context bar, select the shape and then take the "Fill" tool.

Share this post


Link to post
Share on other sites

Go to View > Show Context Toolbar, there should be a tick/check mark at the side of it, if there isn't click on it,  then select the Gradient tool and you should see a toolbar just above the workspace and below the main menu.


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials Instagram & Flickr - Affinity Live 19th June 2019

Share this post


Link to post
Share on other sites
1 minute ago, firstdefence said:

Go to View > Show Context Toolbar, there should be a tick/check mark at the side of it, if there isn't click on it,  then select the Gradient tool and you should see a toolbar just above the workspace and below the main menu.

The OP's screenshot in this post above shows the correct tool selected & the Context toolbar, but I suspect the layer with the bitmap fill was not selected when the screenshot was made, thus the "Type: None" showing in the toolbar.


Affinity Photo 1.7.1, Affinity Designer 1.7.1, Affinity Publisher 1.7.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.1.143 & Affinity Designer 1.7.1.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.3.1

Share this post


Link to post
Share on other sites
Guest

Apparently you just "Place" the bitmap in the document. You have to make it a style to get the options you need.
Select the bitmap on your page, right-click it and choose "Convert to Curves". Right-click again and choose "Create a style".
Select the form to fill with your bitmap, go to the "Style" tab of the studio, search for the style you just created and click on it, it will apply to the form and the options you were missing will be available.

Share this post


Link to post
Share on other sites

Or place a rectangle shape and fill this with the bitmap


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites
6 minutes ago, >|< said:

The Extend control is absent when applying a "bitmap fill" to a Pixel layer.

Apply the "bitmap fill" to a vector object (for example, a Rectangle) instead and the Extend control will be available.

Unless I am missing something, there is still something weird about that screenshot: it shows that the bitmap fill has indeed been applied to the top "(Pixel)" layer -- you can see it in the context toolbar -- but it is not showing up in that layer's thumbnail in the Layers panel. Maybe it is different for the Windows version, but in the Mac one the Layers panel thumbnail always updates to show the fill as soon as the bitmap fill is applied.


Affinity Photo 1.7.1, Affinity Designer 1.7.1, Affinity Publisher 1.7.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.1.143 & Affinity Designer 1.7.1.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.3.1

Share this post


Link to post
Share on other sites

I think it would be best if you gave us the version of Affinity Photo and also uploaded the file for us to look at.


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials Instagram & Flickr - Affinity Live 19th June 2019

Share this post


Link to post
Share on other sites

With the gradient tool selected click on the background layer, the context toolbar will change to show the Extend: options


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials Instagram & Flickr - Affinity Live 19th June 2019

Share this post


Link to post
Share on other sites

Yay! :D 


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials Instagram & Flickr - Affinity Live 19th June 2019

Share this post


Link to post
Share on other sites

I would like to say thanks to >|< for solving the issue for me. I don't understand why it behaves this way, but it is infuriating! The Extend option doesn't show unless in a vector object. I'm attaching a screenshot hoping it might help someone.

screenshot.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×