Jump to content
loktron

Crash on every Instance on Notebook

Recommended Posts

I am Experiencing Frequent Crashes without generated Crash reports on the following two Notebooks:

Dell G5 i5 8300h GTX1060 Max Q 16GB DDR4 2666 Ram

and

MSI G63 Raider 8RF i7 8750h GTX1070 16GB DDR4 2666

Everytime i do more demanding stuff (more layers, erazertool...) The Programm Crashes with no crash report.

Also Windows Error 89e-12292-582 f-4310-b6cc-e70d87a7ca25.

I use Windows 10 Home and Pro respectively with most recent Updates, the latter a fresh clean install.

Newest .Net, newest Nvidia and Intel Drivers.

Deactivating one or the other Video Card doesnt help.

First i thought it has to do with just the one Laptop but now i get it on a completely new on with freshly installed Windows too, so it is defenitly a bug in Affinity...

I cannot Use the programm at all... If this isnt fixed, i want my money back, because the Programm is completely useless to me.

Wich is a shame, because otherwise i love it!

I used it on my mac without any problems, but now i dot have a mac anymore, i cannot use the programm :(

On my Computer at work, with an NVidia Quadro K620  and older i5 3470, 16GB DDR3 Windows 10 Enterprise LTSB 2015 it works perfectly. Never had any problems.

Seems to be a Laptop Problem

Share this post


Link to post
Share on other sites

Hello Gabe, thanks for the quick reply, i didnt get notified, so sorry for the late reply.

As far as i know, i only have RivaTuner along with Afterburner installed of the above. But i tried it on a freshly installed copy of win 10 pro without it too and it didnt change anything.

I noticed in the meantime, that it doesnt crash, if i work on battery. Only if the power supply is connected. So i Think it has to do with the Laptop trying to switch Graphics card. Allthough i tried disabling on or the other solution in Device manager and Bios and that didnt help. Also i tried using the GTX as default option for Affinity in Nvidea Control Panel.

I also tried installing Mac OS on the same Device as i have bought Affinity Mac Edition too, but dont have a Mac anymore and it worked as a charm on Mac OS, despite only using the intel Graphics (MacOS doesnt recognize the Nvidea Card).

On my PC at work it runs perfectly with all the same Software installed .NET and so on), but it is a tower so no switchable Graphics.

If you could help me sort out the crashes, you would be my hero! I really love Affinity! Its a great piece of Software and the only worthy challenger to Photoshop. The Pricepoint is very fair (i would even be happy to pay more to support development, if it works without crashes) please dont ever switch to an monthly fee only!

Share this post


Link to post
Share on other sites

Can you please try this? 

Right click on the Affinity Photo shortcut/exe, and Run it only with the dedicated Graphics card. See if that makes any difference. 

 

Share this post


Link to post
Share on other sites
2 hours ago, loktron said:

I noticed in the meantime, that it doesnt crash, if i work on battery. Only if the power supply is connected. So i Think it has to do with the Laptop trying to switch Graphics card. Allthough i tried disabling on or the other solution in Device manager and Bios and that didnt help. Also i tried using the GTX as default option for Affinity in Nvidea Control Panel.

That's interesting - you may be able to add Affinity to a list of excluded apps for graphics card switching. We can look at reproducing that here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×