Jump to content
Apfel

Collection of various bugs (Affinity Designer)

Recommended Posts

I hope you don't mind me posting this much, but I would really like the bugs I encounter to get fixed, as using Affinity Designer can be a frustrating experience at times. I hope you appreciate the reports.

1. Adjusting location of elements using Transform Studio "glitches"

When using the transform studio to adjust the position of elements by dragging the coordinate values (especially small elements), the element starts to "glitch", or jump around. This gets worse the longer one drags. See the first attached video (This can be reproduced in a new document).

2. Adding text sometimes breaks the viewport

I could only reproduce this in a document that is somehow "broken" I guess. See the second video. When I tap to the left of the lower left artboard with the text tool open, the view jumps "nowhere". You can see me trying to find the artboards by zooming & panning, but they won't show up, I can only get them back by using the navigator studio to reset the viewport. I've also attached the file (Unbenannt.afdesign). (That file also has a bunch of guides I can no longer get rid of).

3. Minor: Changing the name of an artboard only updates in the UI after moving the view port, or closing/opening the document

If I change the name of an artboard, the label above the artboard doesn't update, which caused me to think that I'm doing something wrong. It updates once moving the viewport, or closing and then reopening the document, though.

4. Minor: Symbol behaviour

These aren't really bugs, but I still wanted to mention this: It was little unexpected to me that it's possible to modify a symbol by having sync symbols on and modifying a second instance when the original's layer is locked. I think that locking the layer of a symbol should turn automatic syncing off, don't you think? It was also a little unexpected that the visibility of the layers of the symbols are synced as well (I didn't expect that hiding one symbol hides all the others).

 

Unbenannt.afdesign

Share this post


Link to post
Share on other sites

We really appreciate users reporting bugs. 

I have logged #1,#2 as new bugs. We are aware of #3. #4 is not actually a bug. When the lock is enabled it stops the layer from being accidentally selected when you're working on the canvas area. However, the layer can still be edited. 

Thanks,

Gabe. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×