Jump to content
jc4d

[BUG] HSL strange behaviour with 32 bit images B256

Recommended Posts

Hi all,

If I try to modify the HSL control points on a 32 bit image in  the blue channel for example to green, nothing happens, I have to click on the green channel in order to see the greens affected...(is better a video than words). Everything seems to work fine if I convert the 32 bit image into a 8 bit one.

I'm attaching the sample file.

Cheers,
Juan

HSL_32_bit.zip

Share this post


Link to post
Share on other sites

Hey jc4d,

Sorry about the delay!

Yes I can see what you mean. I'm not entirely sure what is going wrong here so I will let the developers take a look. Hopefully we can either get an explanation or identify a bug. 

Update - If you pick from the stubborn area and drag the two central nodes closer together, it seems to work. I think the answer here is to increase the focus by bringing the nodes together. 

Share this post


Link to post
Share on other sites

Thanks Chris B, but the interesting part is that if the document is in 8 bit color depth, the tool works as it should be.

After you download my file, follow my steps and then repeat the same steps but only after converting the image to 8 bit.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×