Jump to content

Recommended Posts

Hello, i am new to Affinity Designer. So far everything seems perfect, with 1 exception; resizing text frames breaks words instead of flowing the whole word to the next line. Couldn't find any solution, it seems i am the only one having this issue. To clarify i am attaching a video file.

MacOS Mojave 10.14.3 (18D109) | Affinity Designer 1.6.5

Share this post


Link to post
Share on other sites

Hi,

happens sometimes even for words it usually knows in it's dictionary. You can manually force a correct line break after word boundaries via a Shift-Return in such cases.


☛ Affinity Designer 1.9.2 ◆ Affinity Photo 1.9.2 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites

Affinity Designer is primarily not working with text. Have you tried Affinity Publisher? Perhaps the formatting and subdivision of words is better controlled.


Affinity Store: Affinity Suite (ADe, APh, APu) 1.8.5.703.
Windows 10 Pro, Version 20H2, Build 19042.610.
Dell Latitude E5570, i5-6440HQ 2.60 GHz, 8 GB, Intel HD Graphics 530, 1920 x 1080.
Dell OptiPlex 7060, i5-8500 3.00 GHz, 16 GB, Intel UHD Graphics 630, Dell P2417H 1920 x 1080.
Intel NUC5PGYH, Pentium N3700 2.40 GHz, 8 GB, Intel HD Graphics, EIZO EV2456 1920 x 1200.

Share this post


Link to post
Share on other sites

Hi Evren,

Welcome to the forums :)

Firstly, I'd recommend making a copy of this file and trying it in our latest 1.7 beta, as the text engine has been updated and improved to bring Designer in line with Publisher.

Please let me know if your issue still persists in the beta and we can investigate further!

Share this post


Link to post
Share on other sites
33 minutes ago, Dan C said:

Firstly, I'd recommend making a copy of this file and trying it in our latest 1.7 beta...

Hello Dan, unfortunately beta requires a product key, i am still on the trial process to decide if ditching Adobe would be possible.

Share this post


Link to post
Share on other sites
10 minutes ago, Dan C said:

Could you please upload a copy of your .afdesign file, and any custom font files you're using to the following link so I can test it on the beta herre?

I've uploaded a sample file showing the same symptoms with the Google Font Caveat.

Thx again.

Share this post


Link to post
Share on other sites
2 hours ago, Pšenda said:

Affinity Designer is primarily not working with text. Have you tried Affinity Publisher? Perhaps the formatting and subdivision of words is better controlled.

Hello, Publisher seems to fix the problem with character panel language set to English, i was using a custom language library inside macos (Turkish) which failed in the Publisher Beta as well.

Share this post


Link to post
Share on other sites
3 hours ago, Dan C said:

Thanks for confirming that, I'm able to replicate that here so I'll get it logged with our developers now :)

Thanks Dan, it is not a deal breaker for the moment, but it would be great not to manually break lines for every word :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.