Jump to content
Peter Kahrel

Regular expressions: \b works only at word-beginning

Recommended Posts

For me they both work in that the text is found, looking in the results list. However the\b does not highlight the match in the text frame.

And as I mentioned in another topic, a Replace operation involving a \b that matches the end of a word fails.

I also found while experimenting with this that it was a good idea to do a different search (to generate a different results list) in between searching for \bthe and the\b. Otherwise it's hard to determine exactly what was going on.


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

Confirmed: the\b shows the match (with context) in the display panel, but the match isn't highlighted, isn't highlighted when you click the displayed item in the panel, and replace doesn't work either. Refreshing the search panel with another search doesn't improve anything.

Peter

Share this post


Link to post
Share on other sites
1 hour ago, Peter Kahrel said:

Confirmed: the\b shows the match (with context) in the display panel, but the match isn't highlighted, isn't highlighted when you click the displayed item in the panel, and replace doesn't work either.

Confirmed. Seems to be the same issue that I found in the Mac version:)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×