Jump to content
Tapatio

[Fixed] Accent problem in affinity photo

Recommended Posts

Hi,

My version is 1.6.5.123, Windows 10

Since I bought affinity I can't type accents when I use the text tool.
I have a french Canadian keyboard but I have to type Spanish characters sometimes.

So I have to use the Alt Gr key + the accent key followed by the vowel to get á é í ó ú, but it never worked ( see image  attached )

It puts double accent and never put it on the vowel.

 

Thanks for your help

Capture.JPG.d015169e37d8bb02e0f666deae9f570e.JPG

 

Share this post


Link to post
Share on other sites

Sorry but your answer looks like more of someone that likes to avoid to do his job, and that is something you cannot "fake" too.

Look at this image, is clearly a problem of affinity. And in order to have the text well written, I have to write it in another application and then paste it in affinity.

doyourjob.thumb.JPG.58b2eb74e3d0c8a9a8605e5a5f2b031b.JPG

 

Share this post


Link to post
Share on other sites

You might not be aware of how this works, so I will try to explain this for you. 

We only rely on the font glyph characters for all the "special" characters, like accent, superscript, subscript. If those are not present in the font you´re using, they will not display properly. Other apps, "fake" these characters if they are not present as glyphs. I could not replicate that issue using a Spanish keyboard so that´s why I´ve asked you what font you're using and if you can see them in your glyph browser. I'm not entirely sure why you use the Alt Gr key in combination with the ` and the vowels. You would only need either ` + vowel, or ALTGR + numbers:

  • á = Alt + 0225.
  • é = Alt + 0233.
  • í = Alt + 0237.
  • ó = Alt + 0243.
  • ú = Alt + 0250.
  • ñ = Alt + 0241.
  • ü = Alt + 0252

Share this post


Link to post
Share on other sites

Given this answer, sorry  but I stand from what I said. I don't need to know so much technicalities about "glyphs" and "fonts " etc etc etc , I'm a simply end user that wants his tool work as expected. And a software developer too, that's why I'm aware of this kind of answers. 

I will explain the whole situation for the sake or your comprehension: I live in Canada, french Canada to be exactly.  Here they sell only Canadian French and Canadian English layout keyboards. But I have to do some work in Spanish, to a Spanish clients. because I speak Spanish too. Do you want more detail about it ?????

The Canadian French Layout don't have the same accents as Spanish and in order to get the accented vowels as in Spanish ( áéíóú ) you have to presse AltGr + AccentedKey + the vowel.

Why that work well in all other applications but affinity photo ????

So please,  before justify the typing bug in affinity whit technicalities , don't be lazy, do your job, do a research an then come back.

( This is a Canadian French layout keyboard, by the way )

doyourjob2.png.d11dacbe40b681ef15d83bde7e28164a.png

 

 

Share this post


Link to post
Share on other sites

This is what I`ve discovered after some more tests, on a British layout keyboard (We do not have a Canadian-French keyboard). 

If I use the on-screen keyboard, it's all fine. If I use the physical keyboard, it adds 2 `` in front of the accented character. 

However, I tested this in the latest beta and it seems to be fixed (as far as I can test using a British keyboard). Can you install the beta and let us know how it goes?

https://forum.affinity.serif.com/index.php?/forum/34-photo-beta-on-windows/

You can ignore the keystrokes in the top right, they are mapped wrong on my physical keyboard. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.