Jump to content
Jordan Becker

[Fixed] Justified All breaks layout on first line

Recommended Posts

Hi,

 

Starting this topic on request from your reply on my tweet: https://twitter.com/affinitybyserif/status/1097431968562769921

 

So I have a multiline text that has the "Justified All" property set for text alignment.

As you can see in the video, depending on the zoom level of the viewport, the text behaves in a weird manner. As if at some zoom the text is displayed as expected, at some other zoom the first line ignores the Justified All property, and in between there is a glitch that displays half of the text correctly, and half of the text wrong.

 

When exporting, with these dimensions, I got the half/half result. This issue was pretty annoying, and my workaround was to create multiple text layers instead of one multiline.

 

I included the .afphoto document to this thread, as well as the video and screenshot I posted on Twitter.

 

Hope this helps to investigate the issue, as it is very annoying.

 

Best regards,
Jordan

Capture d’écran 2019-02-16 à 17.44.45.png

Thumbnail-WTF.afphoto

Share this post


Link to post
Share on other sites

Hi MEB,

Thank you!

 

Just tested it out using the Customer Beta 1.7.0.110 and I can confirm this effectively fixes the issue encountered!

I guess you can mark this one as solved then :) 

Share this post


Link to post
Share on other sites

Thanks for your help with this bug. We have now resolved the problem and will make the fix available in the next Mac release.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.