Jump to content

Affinity Photo Public Beta (1.1.2.24443)


Recommended Posts

  • Moderators

Purpose: Features / Improvements / Fixes

Status: Beta

Requirements: None

Mac App Store: Not submitted

New beta sign-ups: https://affinity.serif.com/photo

Update: Run the app to get the link

 

Features / Improvements / Fixes

 

- New “live filter” layers (experimental). More to come.

- New Option-Click a layer to edit in isolation - including mask support.

- New “Paste to new document”.

- New ability to add “chords” of colour (complementary, analogous, triadic, etc.) from the Colour or Swatches panels.

 

- All filter panels now support “mirror” before / after, as well as “split”.

- Can toggle visibility of multiple layers using the layers tab.

- Brush presets can now have an attached tool. Selecting the preset will automatically switch to the associated tool.

- Assistant option to control how brushes are shared between brush tools.

- Improvements to Info panel - including memory information.

- Edit->Fill now works properly on mask layers.

- Delete button on adjustment panels now always deletes the whole adjustment.

- Guides can be specified and viewed as percentages.

- Improved polar / rectangular commands.

- Fixed weird colour issues with blur brush.

- PSD import improvements - curves, CMYK, etc.

- Slice export improvements.

- Improved default Vignette settings. More to come.

- Many bug fixes and stability improvements.

- A new sample.

 

- Fixed significant ICC profile problems in Develop Persona.

- Develop Persona now has the Info panel - so the sampler tool has been removed.

- Develop Persona will properly import and apply exposure bias.

- Develop Persona now applies user exposure adjustments correctly.

 

- New / improved camera support for:

  • BlackMagic Pocket Cinema Camera, Production Camera 4k
  • Canon PowerShot A550, A3300 IS, G1 X Mark II, G7 X, SD950, SX60 HS, EOS 7D Mark II, EOS 20Da, EOS 60Da, EOS 1200D, EOS-1D C
  • Casio EX-FC300S, EX-FC400S, EX-Z1080, EX-ZR700, EX-ZR710, EX-ZR750, EX-ZR800, EX-ZR850, EX-ZR1000, EX-ZR1100, ZR1200, ZR1300, EX-ZR1500, EX-100, EX-10
  • Digital Bolex D16,D16M
  • DJI 4384x3288,
  • Epson R-D1s, R-D1x
  • FujiFilm E505, S1, S205EXR, HS10, HS11, HS22EXR, HS33EXR, HS35EXR, F505EXR, F605EXR, F775EXR, F900EXR, X100T, X30, X-T1, X-T1 Graphite Silver
  • Hasselblad H5D-60, H5D-50, H5D-50c, H5D-40, H4D-60, H4D-50, H4D-40, H4D-31, H3DII-22, H3DII-31, H3DII-39, H3DII-50, H3D-22, H3D-31, H3D-39, H2D-22, H2D-39, CF-22, CF-31, CF-39, Stellar II,HV
  • HTC UltraPixel
  • Imacon Ixpress 96, 96C, 384, 384C (single shot only),132C, 528C (single shot only)
  • ISG 2020x1520
  • Ikonoskop A-Cam dII Panchromatic, A-Cam dII
  • Kinefinity KineMINI, KineRAW Mini, KineRAW S35
  • Kodak DCS460D, S-1
  • Leaf Credo 50
  • Lenovo a820
  • Leica Digital-Modul-R, D-Lux (Typ 109), M (Typ 240), Monochrom (Typ 240), M-E, M-P, R8, S, T (Typ 701), X (Typ 113), X2, X-E (Typ 102), V-Lux (Typ 114),
  • Matrix 4608x3288
  • Nikon D4s, D600, D610, D750, D800, D800E, D810, D3300, D5500, Df, 1 J4, 1 S2, 1 V3, Coolpix P340, Coolscan NEF
  • Nokia 1200x1600
  • Olympus E-450, E-600, E-PL6, E-PL7, E-M1, E-M10, E-M5 Mark II, SP565UZ, STYLUS1s
  • Panasonic DMC-CM1, DMC-FZ7, DMC-FZ70, DMC-FZ1000, DMC-GF7, DMC-GH4, AG-GH4, DMC-GM1s, DMC-GM5, DMC-LX100, DMC-TZ60/61/SZ40, DMC-TZ70
  • Pentax GR, K110D, K-01, K-S1, Q, QS-1, 645Z
  • PhaseOne IQ250, IQ260, IQ260 Achromatic, IQ280, Achromatic+, P 20+, P 21, P 25+, P 30+, P 40+
  • Ricoh GXR MOUNT A12, GXR MOUNT A16 24-85mm F3.5-5.5, GXR, S10 24-72mm F2.5-4.4 VC, GXR, GR A12 50mm F2.5 MACRO, GXR, GR LENS A12 28mm F2.5, GXR, GXR P10
  • Samsung GX-1L, NX1, NX5, NX1000, NX1100, NX30, NX300, NX300M, NX3000, NX mini, Galaxy S3, Galaxy Nexus
  • Sigma dp1 Quattro, dp2 Quattro
  • Sinar eMotion 22, eMotion 54, eSpirit 65, eMotion 75, eVolution 75, Sinarback 54
  • Sony A7 II, A7S, ILCA-77M2 (A77-II), ILCE-3000, ILCE-5000, ILCE-5100, ILCE-6000, ILCE-QX1, DSC-RX100III, DSLR-A560, NEX-VG20, NEX-VG30, NEX-VG900, IMX135-mipi 13mp, IMX135-QCOM, IMX072-mipi
Link to post
Share on other sites

I just wanted to mention that this beta, along with the previous betas, still does not remember the last tool used with stacked tools. That is, even though I pick a tool for use (in my case the Inpainting tool) from the stack with the default top of the Healing Brush, save a file and exit, when I restart the tool stack top is set back to the Healing Brush and not the Inpainting tool.

 

That is different from the posting several betas ago that said that this issue had been fixed and would be available in the "next" beta. It is still not there.

Link to post
Share on other sites

Hello:

 

What the correct step for installing and using the latest Beta? So we have to erase the old one or download and reinstall the new one , or is  there an "update" option in the software...?

 

thanks

There is an update option in the software.

Link to post
Share on other sites
  • Moderators

@velarde,

Run your current beta. It will warn you that a new Beta is available. Click on the download button on that dialog. This will direct you to the download website. Download the file (.dmg), run it then drag the app icon to the Applications folder in that dialog. It will ask you if you want to rewrite/replace the previous version. Select yes and it's done.

Link to post
Share on other sites

Wow, these live filter layers are indeed exciting … And this new colour chords feature is also amazing … now we just need a tool like Kuler, but the Affinity way, to be sure … which means, something *really* smart …  :D

 

Just a little cosmetic issue: some panel lists have white backgrounds when you use this "rubberband" effect … sorry, I don’t know how this is called in English correctly … but you will see it in my screen cast …

 

Cheers,

Alex  :)

Link to post
Share on other sites

Very nice!!! Live filters look amazing! One quick UI suggestion: get rid of the word "Filter" after each item in the menubar and pop-up menus for Live Filters. Redundant, we know they are all filters. 

 

Update: also, there are two Add Noise filters in the Live Filters pop-up menu in the layers palette. However, when I add the first one, it makes a new Live Filter in the layer stack named Denoise....

2017 15" MacBook Pro 14,3 w/ Intel 4 Core i7 @ 2.8 GHz, 16 GB RAM, AMD 455 @ 2 GB, 512 GB SSD, macOS Big Sur 11.1

2018 11" iPad Pro 256 GB, latest iPadOS public beta

Link to post
Share on other sites

Also, under Layer > New Adjustment Layer, we don't need the word "Adjustment" after the name of each adjustment. We know they are adjustments, since we are inside the "New Adjustment Layer" submenu. It will help make the menu less cluttered and more legible.

 

 

Very nice!!! Live filters look amazing! One quick UI suggestion: get rid of the word "Filter" after each item in the menubar and pop-up menus for Live Filters. Redundant, we know they are all filters. 

 

Update: also, there are two Add Noise filters in the Live Filters pop-up menu in the layers palette. However, when I add the first one, it makes a new Live Filter in the layer stack named Denoise....

2017 15" MacBook Pro 14,3 w/ Intel 4 Core i7 @ 2.8 GHz, 16 GB RAM, AMD 455 @ 2 GB, 512 GB SSD, macOS Big Sur 11.1

2018 11" iPad Pro 256 GB, latest iPadOS public beta

Link to post
Share on other sites

Don't know if this is a bug in the release or a bug in my ability to use it correctly, but ...

 

For the first time since starting with AP, I needed the denoise filter (to clean up a woodland scene illuminated from the side by the setting sun, shot hand held at 5000 ISO to let me get a decent depth of field).  When the Before and After option is selected before conducting the denoise the  view shows a split screen with those labels.  During and after application of the denoise the split screen itself vanishes (reverts to full screen of the image) as does the toolbar to select splitting.  Nothing happens when trying to select the split view after applying the denoise.

Retina iMac (4K display, 1TB SSD, 16GB RAM) OS X 10.11.6  Capture One 10.

 

Link to post
Share on other sites

Love the live filters! And they're fast too!

 

Would these at some point have the same before and afters as the other filters?

 

Also.. do you really need destructive filters at all? When they are ready for prime time non-destructive should really be default and if you want baked filters then just merge down a layer.

 

Just a thought is all.

Link to post
Share on other sites

To expand on what Ronny said … perhaps you could improve order consistency between the menus … and would you *please* consider inserting dividers between the "functional" blocks of menu items, particularly in the blend mode menu?

 

All this is easily done and would greatly improve the user experience (the same applies to Affinity Designer as well) …  :)

post-1198-0-33436000-1428744504_thumb.png

Link to post
Share on other sites

Thank you — We [Lucid Moth] are so pleased with the product you've created. You truly are a blessing in the HELLISH Nightmare known as "Adobe" a.k.a "Adon'tBe". Truth be told — we haven't been this excited about a creative software in a very long time. We honestly love what you guys are doing. I mean we — absolutely — love the Affinity Eco–System. Even at the beta stage Affinity is so much better than the final stage of Adobe's creative suite.

CS6 is the reference point — F()!K CC or whatever the hell it's called.
 

Whats truly nice is that the forum are filled with lovers of the product. Lovers, that are actually participating in the shaping of what — I / we — can honesty call greatness. Affinity — will be [as the development continues and improvements are made] a true replacement for all things "Adobe". Hell, it has already become that for us.

 

Once again thank you.

15"-inch MacBook Pro, 2017, 2.9GHz Intel Core i7 | 16Gb

Link to post
Share on other sites

Hi everybody,

 

first of all I'd like to thank the programmers for an awesome job. I'm using Affinity Designer quite a while now and I'm thrilled what this program enables me to do. Now I just signed up for the Photo Beta program but after downloading the beta I get the error message that the dmg is damaged. Does anybody else have this problem? I'm on Yosemite 10.10.3

 

Thanks for your help!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.