Jump to content

Japanese Input bug

Recommended Posts

Hi, I'm using Affinity Designer version 1.6.1 on macOS Mojave and found a Japanese input bug that had not existed in the previous version. I now use Google Japanese Input as IME, but the bug still occurs on macOS default Japanese IME.

When I try to input Japanese with text replacement (i.e., conversion; we japanese first input alphabets and then convert them into Kanji, which is like Chinese), replaced texts are selected, so if I continue typing, they are deleted. Hopefully replaced texts should not be selected after conversion. This problem had not been before in the previous version.

This bug is reported by many users on Mac App Store, but many of them are written in Japanese.

I attached the movie of the bug, and I hope it will be fixed soon.


Link to comment
Share on other sites

  • Moderators

Hi Meowmeow,

I've been looking into this and believe I've recreated however I just wanted to confirm with you that this happens after you press the 'Tab' key to select the word and then Enter? Unfortunately I don't personally have any experience with Japanese IME, so its been a bit confusing. Could you confirm what I'm doing to reproduce this is the correct way (Note I'll refer to the keys I'm pressing on an English GB keyboard layout). Note I've had to install Google IME from https://www.google.co.jp/ime/ to reproduce it - I was unable to reproduce using Apple's built in IME. I've also made sure to change the Input Mode in Preferences to Kana from Romana (also did this for Apple's IME but again couldn't reproduce it).

  1. I've translated the word 'Test' on Google as being テスト
  2. Looking at a Katakana keyboard layout I can type this using the letters W, R, S
  3. I then press 'Tab' to select it and then 'Enter' to accept it
  4. It is at this point the word is highlighted, causing it to be overtyped. If I press 'Enter' without pressing Tab it doesn't highlight it.


Link to comment
Share on other sites

Hi Sean, 

Thanks for your reply. You're certainly reproducing the bug. 

On 2/19/2019 at 8:03 PM, Sean P said:


  1. It is at this point the word is highlighted, causing it to be overtyped. If I press 'Enter' without pressing Tab it doesn't highlight it.

Here, hopefully, the word should not be highlighted after replacement with Tab & Enter keys. (The word should not be highlighted after just pressing Enter, because it isn't replaced. This is a normal behaviour. )

Just to let you know: Most Japanese users type テスト by pressing TESUTO instead of W,R,S because they use 'alphabetic input mode' instead of Japanese Kana input mode (refer to the image I attached.), and most of them use Space key to replace texts instead of Tab. Personally I use Apple's US keyboard. Note: I attached an image of Google Japanese Input IME's setting window.

If you're not sure enough about the problem, feel free to ask me more.

Thanks for your effort for improvement!

スクリーンショット 2019-02-20 22.22.48.jpg

Link to comment
Share on other sites

  • Moderators

Thank you very much for that - It is most helpful! I've been trying it again using the Alphabetic input mode and typing Tesuto and have been able to reproduce it in 1.6. I've then tried it in the latest Designer build of (available from the link below) and it does seem to be resolved it that - on pressing Enter the word is no longer being selected causing the overtype.

Would you mind giving the beta a try for me please? Please note that it won't interfere with any of your Store 1.6 settings - the two can be run alongside. :) However what I will warn is that saving a document in the 1.7 beta will cause it to no longer be read by 1.6.


Thank you very much!

Link to comment
Share on other sites


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.