Jump to content
MacGB

Apple Photo's extension edit in changes aspect video

Recommended Posts

Hello Dan C

I did some testing with a RAW file, and using the extension it shortly shows "edit your document in Affinity" and it proceeds as expected and opens the Photo in Affinity Photo

However it changes the aspect ratio !

Let me explain. I shoot with a Panasonic G80 and use the Panasonic Lumix Vario 14-140 mm zoomlens. The camera is a four-third camera, however I always shoot in a 3:2 aspect ratio (in camera setting). Now the strange thing: When using the extension "edit in Affinity.." the aspect ratio from the camera is ignored. So it defaults to the aspect ratio 4:3 in stead of the camera setting 3:2. However when I use the Apple Photo's function "edit with" and then choose Affinity Photo Beta, the aspect ratio 3:2 is preserved.  

In the present Affinity the aspect ratio is alway preserved as set in the camera.

Using the other extensions from Affinity Beta, the aspect ratio is preserved as well. 

Keeping the aspect ratio from the camera settings is very important for me. Helas I did notice that even DXO-lab (and some others I am experimenting with)  doesn't keep the aspect ration as set with this camera. (with my former G7 using the same lens this was no issue)

I hope, in the end, keeping the right aspect ratio, as set in the camera, will be available in the version 1.7

By the way if I find some other anomalies where can I report them (I noticed for instance that the extension Develop started up Affintiy-develop but wasn't able to write back to Apple Photo's)

Share this post


Link to post
Share on other sites

Hey MacGB,

I thought I'd reproduced this initially but when I went to log the steps with development, I went through it again and it was fine. Would you mind attaching one of the images for me please? 

Share this post


Link to post
Share on other sites

Hello Chris B

Thanks for your reaction.

(@ Dan C and you: I posted again in the earlier thread. I didn't see my answer, so I thought I had forgotten to sent it :$)

I attached an original RAW from my G80.

I my post it appears now that I made a mistake. When I open those pictures directly with the Affinity Photo 1.7 beta the aspect ratio is changed as well.

So:

-using the extension "edit in Affinity 1.7" the aspect ratio is changed.
-using Affinity Photo1.7 as stand-alone and then open the picture: the aspect ratio is changed as well.
-using the other extensions from Affinity Photo 1.7 the aspect ratio is not changed.

using the function of Apple Photo's "edit with" and then choose Affinity Photo 1.7, the aspect ratio is also not changed.

In the present formal release of Affinity Photo 1.6.11, there is no change of the aspect ratio.

Edit Further testing and comparing shows me that using 1.6.11 as stand-alone for the RAW-file also changes the aspect ratio. Could have sworn that this didn't happen before I installed the 1.7 beta, but perhaps I am mistaken. I am sorry for not noticing that earlier.

If you have any further questions please let me now.

Thank you for your support.

 

 

_1000815.RW2

Edited by MacGB

Share this post


Link to post
Share on other sites

Thanks for that. I've poked it some more and the cause might be our raw engine. If you go to Assistant Options > Develop Assistant, is your RAW Engine set to Serif Labs? If so, change it to Apple (Core Image RAW) and try again. These are my results:
 

Apple Core
Edit in - 3 : 2
Edit with - 3 : 2
Open directly - 3 : 2

Serif Labs
Edit in - 4 : 3
Edit with - 3 : 2
Open directly - 4 : 3

Edit in and opening directly shove it through the Develop Persona which is why we are getting different results in Serif Labs. If I Edit with > Affinity Photo, it opens directly in the Photo Persona and gives the correct result.

Share this post


Link to post
Share on other sites

Hey Chris,

Thanks for sorting that out. That did the trick,

Noticed also that with the "edit with", it opens a tiff and not a RAW.

One tiny problem now (but don't bother) if I try to use the "edit in" extension from Affinity Photo 1.6.11 it opens up Affinity 1.7 beta, no way that I can get 1.6.11 to pen with this command.

Tried deselecting all extensions and rebooting my system to no avail. But then again it's no problem; glad that you figured this out and that the "open in" extension is working properly in 1.7

Share this post


Link to post
Share on other sites

I get two 'Edit in' options, both say 'Edit in Affinity Photo' but they have different icons (or they should). The square icon should be the beta and the original triangular icon will be the release version.

I've logged this with the developers so they should see what's going on.

Share this post


Link to post
Share on other sites

Hello Chris,

Thanks again. Yes I see both as well (different icons), but they both open the beta version :). But then again it is no problem for me. I suppose when I would delete the beta it will work with 1.6.11, but for now I am going to experiment a bit further with the beta.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.