Jump to content
Sign in to follow this  
IndigoMoon

Developing Performance #240

Recommended Posts

1 hour ago, IndigoMoon said:

Thanks Mark, well done!

Pressing the Tone Mapping Icon improves now on my machine to 19 seconds and no crashes anymore repeating the procedure.

But #243 still takes longer for developing, so I did some investigation... Noise Reduction

Thanks for those results. Does it continue to take ~19 seconds if you repeat the procedure? I note that in 1.6 it got slower each time you tried.

It should be quicker to load a RAW file, but slower to Apply in Develop Persona. This is due to a change in the Develop algorithm in 1.7 builds (it now produces a better result, at the expense that it takes longer).

Share this post


Link to post
Share on other sites
35 minutes ago, Mark Ingram said:

Does it continue to take ~19 seconds if you repeat the procedure?

Yes, always 19 seconds or even reduced to 17 - 18 seconds. So, no accumulation anymore.

38 minutes ago, Mark Ingram said:

...but slower to Apply in Develop Persona...

But it seems only the new noise reduction algorithm slows down the development significantly.

Share this post


Link to post
Share on other sites
43 minutes ago, IndigoMoon said:

Yes, always 19 seconds or even reduced to 17 - 18 seconds. So, no accumulation anymore.

Great. That's what we were hoping to achieve. There was a problem in all previous versions that would cause operations to gradually get slower over time. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×