Dan – I'm using a copy I originally purchased  from the Mac App store which has been automatically updated to 1.7.0