Jump to content

Duplicating group of items makes one "disappear"

Recommended Posts

Hello, first of all I'm a HUGE fan of Affinity Designer, you guys are awesome :)

I have Ipad and Mac versions and this bug happens in both of them. I make a lot of seamless patterns and this bug is affecting my work real bad. I made a quick video to show you how the bug occurs and is very easy to duplicate the error, in my iMac and iPad pro this happens all the time.

When selecting groups of objects and using the Cmd+J duplicate command, after positioning the duplicate objects, one of the original just "disappears" from the screen, but when you look at the layers panel the object is there, but when clicking the object through the layers panel, the selection box is far away from the object. I just tried to use symbols for making seamless patterns and this bug makes it impossible to use.

My object in this video is a group of two pixels layers, but just tested with vector layers and happens the same thing.

I hope is some easy fix :) Thanks a lot!


Share this post

Link to post
Share on other sites


Sorry to bother you again guys...just trying to provide you more clues to this error...

This time inside symbols, duplicating items keep doing all kinds of crazy things. Same disappearing problem and even changing items colors :(

I do use symbols a lot for making seamless patterns, it's fantastic by the way. But now I just can't use it at all.

Attached the file that I'm working with.

Thanks again!



Share this post

Link to post
Share on other sites

I cannot explain the bounding box being offset from the actual contents of the object. That seems odd.

However, I have a thought about a possible workaround: Cmd+J invokes the "power duplicate" function, which does more than duplicate an object. Perhaps the additional functions are doing something unexpected for you.

If all of your problems are related to objects where you've used Cmd+J multiple times, perhaps you could try using Cmd+C (Copy) and Cmd+V (Paste) instead?

-- Walt

Windows 10 Home, version 1809, 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo and Beta       / Affinity Designer 1.6..5.123 and Beta    / Affinity Publisher Beta

Share this post

Link to post
Share on other sites

Hi Walt, thanks for your help. 

I tried to use Copy and Paste, but as recorded on second video, it creates weird things too, like changing the mermaid's blush color. It's really odd.



Share this post

Link to post
Share on other sites

Hi both. 

affinity-designer-bug.afdesign - I cannot replicate it. Have you tried to zoom in/out when that happens? it looks like a redraw issue to me. 

seamless-pattern.afdesign - One is an issue, one is not. The duplicate command seems to work weird on that file, and I will log it with our developers. In the second part of the video you see an expected behaviour. Your symbol is clipped by that rectangle, so you would have to do the same thing as you've done with his element here: 


You would have to place the element on each square. 



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now