Jump to content

Recommended Posts

I used the previous version of affinity without any error on m windows 10 system. Now I wanted to use it again and get an invation to download the latest version. The setup starts, but there is no window opening. A few seconds later the icon in in the taskbar disapperas and nothing else happens. I tryed to deinstall the old version, download the file again and to restart my pc, but the setup wont run.

Share this post


Link to post
Share on other sites

I just downloaded AFFINITY PUBLISHER tonight onto my brand new laptop and have spent 3 hours trying to get the thing to install.  Get Affinity SETUP dialog box saying failed to start setup, saying Microsoft. NET 3.5 has been turned off on this computer.  Tells you to Open Windows Features app to turn it on.  But info in threads last fall said install errors were happening if 3.5 was on, so use 4.2 if loaded on computer.  But I tried it with3,5, without the 3.5 and with the 4. option, it just does nothing.

Mind you, I've been using AFFINITY PUBLISHER on my other laptop since the fall with no problems installing.  Though I am NOT going to install to the newest version :- ) now.

Any ideas how to fix, Affinity?  I'm sure we're not the only 2 with this problem.

Alternatively :- ), is it ok if I just install a previous version(still in my downloads folder on the old computer) on the new computer for now?  (I was not sure if I could use the download from my existing laptop (which works fine right now) on more than one device, so I opted to download straight from affinity and got the newest version. 

LOVE PUBLISHER, by the way.  I still use PAGES believe it or not, though it crashes on me mercilessly and have been awaiting PUBLISHER for a couple years now. :- )  Hope all my PAGES documents can be imported - please, pretty please - when PUBLISHER is finally ready.

Share this post


Link to post
Share on other sites
50 minutes ago, Wishful said:

I just downloaded AFFINITY PUBLISHER tonight onto my brand new laptop and have spent 3 hours trying to get the thing to install.  Get Affinity SETUP dialog box saying failed to start setup, saying Microsoft. NET 3.5 has been turned off on this computer.  Tells you to Open Windows Features app to turn it on.  But info in threads last fall said install errors were happening if 3.5 was on, so use 4.2 if loaded on computer.  But I tried it with3,5, without the 3.5 and with the 4. option, it just does nothing.

Mind you, I've been using AFFINITY PUBLISHER on my other laptop since the fall with no problems installing.  Though I am NOT going to install to the newest version :- ) now.

Any ideas how to fix, Affinity?  I'm sure we're not the only 2 with this problem.

Alternatively :- ), is it ok if I just install a previous version(still in my downloads folder on the old computer) on the new computer for now?  (I was not sure if I could use the download from my existing laptop (which works fine right now) on more than one device, so I opted to download straight from affinity and got the newest version. 

LOVE PUBLISHER, by the way.  I still use PAGES believe it or not, though it crashes on me mercilessly and have been awaiting PUBLISHER for a couple years now. :- )  Hope all my PAGES documents can be imported - please, pretty please - when PUBLISHER is finally ready.

Hello @Wishful,

welcome to the forum.

A new laptop sounds (perhaps) like a high screen resolution. There seems to be a bug with certain display scaling settings on Windows.
See this post by Pauls.

The solution is to temporarily reduce display scaling during install and switch back afterwards. Maybe that works for you?

There is another long thread about this problem here.

I hope you get up and running soon :)
d.


Affinity Designer 1.7.1.404 (beta 1.7.1.404) - Affinity Photo 1.7.1.404 (beta 1.7.1.404) - Affinity Publisher 1.7.1.404 - Affinity Designer for iPad 1.7.0.7 - Affinity Photo for iPad 1.6.8.77

Windows 10 (1809) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites

Hi Dominic,

WOW, you are a wizard!  It's 1 am here and I am bleary eyed BUT I now have AFFINITY PUB installed and running on my new LENOVA 2n1!  Thank you, thank you, thank you!

As soon as I saw your post, we did 3 things - dropped scaling back to 100%, dropped resolution down to 1920x1080 (it was really high) AND!!!!!!!!!! removed 2nd monitor just for the install.

Worked like a charm! 

Best of luck to all others having this problem.  I think the scaling was a problem but I also think (at least for me) the large 2nd monitor (it's huge) was causing some problem.

SO HAPPY I can do my creative work in the morning.

Thanks so much for the reply, "D".  Now this 60 yr old girl can go to bed!!! ;-)

Night all and best of luck.

Share this post


Link to post
Share on other sites
36 minutes ago, Wishful said:

Hi Dominic,

WOW, you are a wizard!  It's 1 am here and I am bleary eyed BUT I now have AFFINITY PUB installed and running on my new LENOVA 2n1!  Thank you, thank you, thank you!

It's my pleasure.

Glad to see you up and running ... and sleeping well :)

d.


Affinity Designer 1.7.1.404 (beta 1.7.1.404) - Affinity Photo 1.7.1.404 (beta 1.7.1.404) - Affinity Publisher 1.7.1.404 - Affinity Designer for iPad 1.7.0.7 - Affinity Photo for iPad 1.6.8.77

Windows 10 (1809) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×