Jump to content
WatcherMagic

[By Design] Inconsistent Pixel Brush Line

Recommended Posts

I'm using a Huion H610PRO tablet, and when trying to use a simple pixel brush in Affinity's pixel mode I get oddly shaped lines, like this:

263206437_Screenshot(1126).thumb.png.344a03abb34c3b5f1b0ffd56fcc5b917.png

I don't experience this using other programs, such as Mischief or Pencil2D so I know it's not the tablet. Occasionally I can solve this by closing the program and opening again; does anyone know what causes this and how to stop it?

Share this post


Link to post
Share on other sites

Try drawing at 100% for testing purposes. I find funny things sometimes happen at "awkward" zoom percentages... such as 57.6%. That can also make the lines look odd, because I've noticed anti-aliasing at weird percentages don't look as "clean" as in other programs... when you save these out, do they produce the correct look?


Microsoft Windows 10 Home (Build 19041)
AMD Ryzen 5 3600 @ 3600Ghz; Mobo: Asus X470-PRO
32GB DDR4 (3000Mhz)
NVIDIA GeForce GTX 1060Ti 6GB
Monitor 1: 4K @ 150%
Monitor 2: 4K @ 200%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Share this post


Link to post
Share on other sites

I've tried experimenting a bit, I've labeled the screenshots so you'll know what I've done. Line spacing doesn't seem to make much of a difference, zoom helps but I'm not sure that's the "right" look I'm going for. It could just be the pixel persona, but the lines still look wonky to me. Correct me if I'm wrong.

931226409_Screenshot(1127).thumb.png.12368e0b9d8132ec7ee3ac1b0ab52f94.png1937709364_Screenshot(1128).thumb.png.46cd18f1d4102f0b4d2c72d2d0f5787d.png878088158_Screenshot(1129).thumb.png.571c5ab68bfbc79510f8556bdb9ff086.png

Share this post


Link to post
Share on other sites
1 hour ago, WatcherMagic said:

Yup, I took a screenshot with nothing but google going on in the background, and one with AD running:

Although I'm not sure why your disk usage is at 99% (without looking at disk activity in 'Resource Monitor'), I think they meant a screenshot of [Edit > Preferences > Performance] from inside Affinity Designer, so they can see what the settings such as 'View Quality', etc. are set to.  If 'View Quality' is set to 'Nearest Neighbour', does changing it to 'Bilinear (Best Quality)' improve the appearance?

 

Share this post


Link to post
Share on other sites

OH-I'm a nut. ^^' Sorry about that, I've been messing with code so my first instinct was "oh, system performance!" That being said, yes that fixes it! Thank you both so much, I know this ran a little long.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.