Jump to content
iBaloo42

[Fixed] Brush size and hardness control with a tablet pen in Affinity Photo

Recommended Posts

The brush size/hardness control is working on Affinity by using Alt+Mouse_RC+Mouse_LC.

However, there is no way of doing the same thing using a tablet pen (tested with Wacom Intuos Pro). I should be able to do this very easy, similarly as demonstrated in this video with Photoshop.

This issue is reproducible in the beta release 1.7 as well.

Share this post


Link to post
Share on other sites

Hi @iBaloo42,

I'm not sure why you struggle. 

If you have a modifier key on your tablet set as ALT, and the button on your pen set as right click, you can just press the modifier key, the button on your pen and by touching the tablet you have "left click". You can then drag up/down/left/right to adjust the brush settings. 

Thanks,

Gabe. 

Share this post


Link to post
Share on other sites

Hi @GabrielM,

I did that, both by using the ALT key from the keyboard, and from an ExpressKey assigned to the tablet. The action that Affinity is selecting is Color Picker. It behaves like the right-click button from the pen is being ignored by Affinity on the brush mode. To be more specific, I'm running on Windows 10 Pro.

 

Regards,

Iulian

Share this post


Link to post
Share on other sites

Actually, there are many more issues with using the pen in Affinity on Windows. You should see me trying to chase the points on the Curves adjustment filter. Or trying to get sliders on any adjustment tools to move the needle.

 

The problems are not related to the Wacom tablet driver, but with the way Affinity is handling Windows Ink. I had the same problems with a Huion and a Monoprice tablet. For comparison, I have played around with the Krita and Medibang, where the pen support is smooth.

Regards,

Iulian

 

Share this post


Link to post
Share on other sites

When you use the ALt + right click + touch, do you use them in this order? Alt , then Right click, then touch? Otherwise, it will not work. 

As for the other issue, can you please be more specific? 

Share this post


Link to post
Share on other sites
58 minutes ago, GabrielM said:

As for the other issue, can you please be more specific?  

If you don't mind others to get more specific ;o) Have a look here.

For the sake of clarity I should add that the second issue I raise in the linked post disappeared after unchecking 'experimental precision input' or similar (not on my desk right now). The hover click issue is still open.

Share this post


Link to post
Share on other sites

The video linked by the thread opener shows basically everything which makes editing with a tablet a far superior experience in Photoshop: Really well functioning brush controls, but also far better scrubby Zoom and Pan.

Superficially looking one might say that this all functions similarly in Affinity - but it's really the details which make all the difference. I described the Zoom and Pan issue with a Pen (also valid for Mouse based input) here.

Share this post


Link to post
Share on other sites
6 hours ago, GabrielM said:

When you use the ALt + right click + touch, do you use them in this order? Alt , then Right click, then touch? Otherwise, it will not work. 

As for the other issue, can you please be more specific? 

The order of actions does not matter, I still cannot get it to do what I can do with the mouse.

Share this post


Link to post
Share on other sites
15 minutes ago, iBaloo42 said:

The order of actions does not matter,

The order of actions DOES matter. If you touch in between Alt and Right click, it will not work. You have to follow that sequence. 

Share this post


Link to post
Share on other sites
1 hour ago, GabrielM said:

The order of actions DOES matter. If you touch in between Alt and Right click, it will not work. You have to follow that sequence. 

I meant that regardless of the combination I'm using, there are only six and I tested them all, I don't get it to resize the brush.

Share this post


Link to post
Share on other sites
7 hours ago, iBaloo42 said:

I meant that regardless of the combination I'm using, there are only six and I tested them all, I don't get it to resize the brush.

So, I did more tests.

Wacom PTH660 and  Intuos Draw CTL 490 behave the same on Photo 1.6 and the 1.7 (beta), the pen's right click is not captured for the alt+rc+lc combination. These Wacom tablets are failing on this test (both tablets are using the same Wacom driver, Wacom's latest).

The Tablet HUION Inspiroy Q11K V2 is fully rejected by 1.6; however, it works excellent in 1.7 (beta), being able to resize the brush, being very precise with the GUI sliders used in the adjustment layers, including very precise control of manipulating the curve points in the Curves Adjustment Layer. There is a bug in 1.7 though, the option that should toggle off the pen pressure support (Force pressure to control size) is not working.

 

Share this post


Link to post
Share on other sites

We've seen it in the past where there's a conflict between Huion, Wacom and Windows INK, all installed at the same time. Can you please try this:

Uninstall all the tablet drivers ( Both Wacom and Huion ). Reboot . Install just one Wacom and see if it works. 

Share this post


Link to post
Share on other sites
11 hours ago, GabrielM said:

We've seen it in the past where there's a conflict between Huion, Wacom and Windows INK, all installed at the same time. Can you please try this:

Uninstall all the tablet drivers ( Both Wacom and Huion ). Reboot . Install just one Wacom and see if it works. 

I've uninstalled all the Wacom and Huion drivers with Wise Program Uninstaller and removed any file and registry residuals. I have also searched and removed any registry keys related to these drivers.

I have rebooted the system and installed the Wacom driver.

I have rebooted again.

The Wacom pen is not working in Photo 1.6, but it is working properly in 1.7 (beta)

 

So, on my system (Lenovo Yoga 920 with Windows 10), Affinity Photo 1.6 is not working with drawing tablets, but it seems that everything is going to be OK on the upcoming 1.7 release.

 

You can consider this issue as closed, from my standpoint. 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.