Jump to content
simonlayfield

Affinity Designer curves disappear when using Union tool

Recommended Posts

Hey team,

Couldn't find this on the forum but unsure if it's a bug or expected behaviour due to the complexity of the curves.

I have a number of unclosed curves drawn using the vector brush tool. I need to be able to close the curves and combine them in to one curve so that I can use them as a mask for another layer. Closing the curves seems fine, but then unfortunately when using the Union tool some of the curves disappear.

Is there a reason as to why this might be? See below

affinity-union-issue.gif.3106d5086a7f8b361bf203c2fc267728.gif

Thanks

Share this post


Link to post
Share on other sites

Sure no problem! I've reduced the file down to just the elements that are causing the issue.

In the file there are a number of groups (flowers). If you Ungroup all, select Close Curve (so that all curves are closed and can be merged together as shapes) then hit Add you'll see some of the petals disappear.

 

affinity-union-bug.afdesign

Share this post


Link to post
Share on other sites

Thanks. This seems to be a bug we are already aware of: adding 2 curves with just 2 nodes fails sometimes. The workaround, for now, is to select the objects that fail and reverse the curve. That should fix it. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×