Jump to content
plobnop

32-bit Preview OCIO Display Transform uses Display 1 monitor profile

Recommended Posts

It looks like AP, when viewing an image with the 32-bit Preview OCIO Display Transform checked, is using the monitor profile for Display 1 on Windows 10. In 1.6 of AP it seemed it was incorrectly using the monitor profile of the Primary Display for both ICC Display Transform and OCIO Display Transform. Now, with 1.7, ICC Display seems to be correctly choosing the monitor profile of the display AP is being shown on. However, OCIO is still incorrect but in a slightly different way than it was in 1.6.

Share this post


Link to post
Share on other sites

Hey plobnop,

Could you explain why OCIO is still incorrect in the 1.7 beta? What are you comparing it to and what suggests that it is wrong? I'm not suggesting anything isn't wrong, I just want to make sure if there's an issue with the app that I understand it so we can get it logged correctly with the developers.

Share this post


Link to post
Share on other sites
Hey Chris, sorry it has taken so long to reply... got busy and forgot to check back. 
 
Monitor/Profile Configuration:
So, I'm using a BenQ and a Dell monitor for my two displays. The way in which these monitors are calibrated are very different. The BenQ uses sRGB color profile for windows color management and has a calibrated LUT on the monitor hardware to provide color calibration. The Dell has a calibration profile selected at the OS level.
 
ICC behavior:
If I open an 8bit image in both AP and Photoshop (sRGB color space) they match when displayed on either monitor. When I move it from one monitor to the other I can see the the color in the image change when the proper profile is applied (in both AP and Photoshop). 
 
OCIO behavior:
  1. Convert 8bit sRGB image to ACEScg (Equivelent to Nuke: Read (Output - sRGB))
  2. Open 8bit sRGB image.
  3. Convert to sRGB Linear 32bit.
  4. OCIO adjustment layer
    • Source: Utility - Linear - sRGB
    • Destination: ACES - ACEScg
  5. OCIO adjustment layer
    • Source: ACES - ACEScg
    • Destination: Utility - sRGB - Texture
  6. OCIO adjustment layer
    • Source: Output - sRGB
    • Destination: ACES - ACEScg
 
When compared to the original 8bit sRGB image (Photoshop and AP) the above 32bit image in ACEScg should be indistinguishable. In AP 1.6 on my primary display they do match. With AP 1.7.0.209 they do not match. So, OCIO is displaying the image differently than the original.
 
Originally I thought AP was using the profile of the primary display. However, If I set the color profile of my second monitor to the profile of the primary (So, AP will use that profile for the ICC displayed image) ICC and OCIO still display differently. So, all I can say at this point is OCIO is displaying oddly on a second monitor. On my primary display OCIO and ICC display exactly the same.
 
Additionally, I'm using an OCIO 1.0.3 config.
 
Hopefully this makes things clear.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×