Jump to content

Recommended Posts

Hi. 

Since the last update, apparently I am having an issue with guidelines. When I try to pull down a guide line from the ruler, it just won't show on the page where I wish to place the guide line but I actually find the line on the first page of the book. 

Otherwise, very promising software like the rest of your suite and I am intending to make our next catalogue and publishing projects on Publisher. 

 

Share this post


Link to post
Share on other sites
2 hours ago, noxdiurna said:

Since the last update, apparently I am having an issue with guidelines.

I can confirm that. Strange things are happening with the guidelines.


My Specs:
- Processor: AMD Phenom™ II X4 955 Processor 3.20 GHz- RAM: 8 GB
- Graphics card: NVIDIA GeForce GTS 250
- Monitor: SyncMaster F2380 (resolution 1920x1080)
- Operating system: Windows 10 Pro (1803) / 64 bit

Share this post


Link to post
Share on other sites
3 hours ago, Michail said:

I can confirm that. Strange things are happening with the guidelines.

This must be a Windows-only problem.    They are working perfectly with my MAC OS Sierra and v. 206.    

Share this post


Link to post
Share on other sites

I can also confirm that for Windows 10.

Trying to add a new guideline to page 12 makes it appear on page 1.


Windows 10 Pro x64 (1809). Intel Core i5-4670K @ 3.40GHz, 16 GB memory, NVidia GTX 780
Affinity Publisher Beta 1.7.0.221

Share this post


Link to post
Share on other sites

Hey Morgoth,

Have you got 'Show Guides' disabled in the View menu? If it is disabled, they won't show on the page but you will be able to see them in the ruler. Dragging out a new guide will re-enable 'Show Guides' to make them appear.

If that isn't it, I'm not sure what else is might be causing this. I'll have to do some poking! 

Share this post


Link to post
Share on other sites
17 hours ago, Chris B said:

If that isn't it, I'm not sure what else is might be causing this. I'll have to do some poking! 

With me, placed guide lines sometimes appear, and sometimes not.
There was already a similar thread:

 


My Specs:
- Processor: AMD Phenom™ II X4 955 Processor 3.20 GHz- RAM: 8 GB
- Graphics card: NVIDIA GeForce GTS 250
- Monitor: SyncMaster F2380 (resolution 1920x1080)
- Operating system: Windows 10 Pro (1803) / 64 bit

Share this post


Link to post
Share on other sites

I've merged both threads.

Am I correct in assuming that you can get this issue to happen on a new document or an existing one? If it only happens on an existing document, I'd appreciate a sample document :) 

I've had another go this morning but I still cannot reproduce it.

Share this post


Link to post
Share on other sites

Yup, very strange behaviors with guides. Seems, repeat seems, to be somehow affected with multiple pages. It looked alright (initially) with a single page, but when using guides on pages 2-> then weird behavior where the guides sometimes show and sometimes don't. I even had it where the guides manager showed guides from another page. Reproduce by creating a 2 page doc. Add guides on page 1 then play with guides on page 2... sometimey.

Win 10, AP beta 206, beta 221

OS Name:                   Microsoft Windows 10 Pro
OS Version:                10.0.17134 N/A Build 17134
 

Share this post


Link to post
Share on other sites
1 hour ago, Chris B said:

Am I correct in assuming that you can get this issue to happen on a new document or an existing one? If it only happens on an existing document, I'd appreciate a sample document :)
I've had another go this morning but I still cannot reproduce it.

I've just created a brand new document. It actually seems to be a problem that only occurs with documents with multiple pages. The guides seem to be placed half on the current page and half on page 1.

In addition, vertical guides do not even display the markers on the vertical ruler.

Guides.gif


My Specs:
- Processor: AMD Phenom™ II X4 955 Processor 3.20 GHz- RAM: 8 GB
- Graphics card: NVIDIA GeForce GTS 250
- Monitor: SyncMaster F2380 (resolution 1920x1080)
- Operating system: Windows 10 Pro (1803) / 64 bit

Share this post


Link to post
Share on other sites

It seems that every time it places a guide it is setting page 1 back as the current spread instead of the one you are on so it is basing the next guide placed off page ! then it will setthe page your actually on as current spread and allow you to place a guide then it will switch back again and so forth

I shall get this passed on to the development team


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites
21 hours ago, Chris B said:

Hey Morgoth,

Have you got 'Show Guides' disabled in the View menu? If it is disabled, they won't show on the page but you will be able to see them in the ruler. Dragging out a new guide will re-enable 'Show Guides' to make them appear.

If that isn't it, I'm not sure what else is might be causing this. I'll have to do some poking! 

All guides are visible and this issue seems to be intermittent. Sometimes it happens and then it doesn't 

 

Share this post


Link to post
Share on other sites
2 minutes ago, Morgoth said:

All guides are visible and this issue seems to be intermittent. Sometimes it happens and then it doesn't 

 

Yes we have discovered the cause, as mentioned above by Chris_K. It's logged with the developers and I'm hoping for a quick turnaround on this one. 

Share this post


Link to post
Share on other sites
Just now, Chris B said:

Yes we have discovered the cause, as mentioned above by Chris_K. It's logged with the developers and I'm hoping for a quick turnaround on this one. 

Have I ever said how much I appreciate the work the team is doing? If not, keep on rocking with the development.

Share this post


Link to post
Share on other sites

Will this fix be available for the Mac version as well? I just noticed the same issue with guides not being able to dragged out with previous-version multiple-page documents under macOS Sierra. :o

Share this post


Link to post
Share on other sites

@noxdiurna Can you add the tags "1.7.0.206" and "1.7.0.221" to indicate both versions as affected by this problem? Thank you.

 


Windows 10 Pro x64 (1809). Intel Core i5-4670K @ 3.40GHz, 16 GB memory, NVidia GTX 780
Affinity Publisher Beta 1.7.0.221

Share this post


Link to post
Share on other sites

So I refer to the announcement of 221... this is still an issue with multiple pages. Easy to recreate - create new document with 2 pages (or if you prefer n pages where n > 1). Guidelines on page 1 work just fine. However, on pages n (n > 1) these guidelines are flaky, sometimey, unpredictable. As Michail shows above. Oh well, that's why is a beta.

Share this post


Link to post
Share on other sites

It was not mentioned in the changelog. So there is no reason to assume it should be fixed in 221.


Windows 10 Pro x64 (1809). Intel Core i5-4670K @ 3.40GHz, 16 GB memory, NVidia GTX 780
Affinity Publisher Beta 1.7.0.221

Share this post


Link to post
Share on other sites

I'm having the same issue with the guides. Sometimes dragging a guide from the ruler works, sometimes not. It seems to work less with vertical guides. "Show all Guides" is enabled, happens in new documents and old documents. Windows 10. Publisher 1.7.0.206

Otherwise it's a great program and miles better than Quarkxpress 2018.

Share this post


Link to post
Share on other sites
On 1/19/2019 at 8:33 AM, Panchdara said:

So I refer to the announcement of 221... this is still an issue with multiple pages. Easy to recreate - create new document with 2 pages (or if you prefer n pages where n > 1). Guidelines on page 1 work just fine. However, on pages n (n > 1) these guidelines are flaky, sometimey, unpredictable. As Michail shows above. Oh well, that's why is a beta.

Fix not not mentioned again in 227.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×