Jump to content
JDWrightBrain

Bug Report: Locked Background not Locking

Recommended Posts

I'm using the 1.7.0.3 Beta of Designer for Mac and basically I have a Pixel layer I'm using as a Background layer for tracing.  Even though I lock it, I'm still able to accidentally move it with my cursor. It's a pain in the ass when I go to adjust my lines and I keep grabbing the background.  This would make the program unusable for me.

Share this post


Link to post
Share on other sites

Really? O.o

I cannot easily reproduce that. The only way I am able to come close to your observation is by grouping the pixel layer and locking the group (or making it a child of another layer and locking the latter one). Now, when I select the pixel layer in the layers list, I can move it, despite the group (the other layer) being locked. Personally, I don’t like this behaviour, but it seems to have been always like that.

Could you provide a screenshot of the layer structure of your document? :)

Share this post


Link to post
Share on other sites

Oh sure. I'm attaching the "problem" structure and what I found that seems to work. 

The first structure was the default when I took a scan of my sketch (jpg) and dragged and dropped it over the AD icon in my Toolbar. 

image.jpg

Share this post


Link to post
Share on other sites

Hmm … that’s interesting. The first structure seems to work perfectly for me. I will never be able to grab the background layer. What could be wrong here? O.o

Share this post


Link to post
Share on other sites

Hi JDWrightBrain

When the pixel layer is on the bottom of the stack I can select it but I'm not actually able to move it in any way. When selected the transform handles should shows as X instead of circles


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

This is exactly what I am seeing. I can select the bottom layer in the layers list (referring to the structure on the left of the screenshot), but not move the layer in any way.

Share this post


Link to post
Share on other sites

I don't know guys. Even when I make a pixel layer and lock it I can still select it and move it around.  Here is a screenshot.  My cursor dropped our but notice the "x's" are anchors in this picture.  I can move the layer around.  It doesn't happen instantly. You have to keep clicking and dragging.  Then it comes "loose".

Screen Shot 2019-01-11 at 8.51.24 AM.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×