Jump to content

Can't open a file ("damaged") saved from the iPad app

Recommended Posts


I've been mostly drawing in Affinity Designer for iPad Pro, but when I want to open it on my MacBook Pro with Affinity Designer for Desktop, it says it can't open the file as it seems damaged. I tried saving the file from the iPad on Dropbox, iCloud or even on my local storage then send it back to my Mac with Airdrop, and I always end up with the same message. 

Any solutions? I was hoping to be able to switch to Affinity Designer on desktop to edit files I start on the iPad.


Share this post

Link to post
Share on other sites

Hi @Cosmocat,

Welcome to the forums.

Have you tried using a different file? Like a new document? I'm thinking if there is a problem with that specific project file you have got. 



Share this post

Link to post
Share on other sites

Hello @GabrielM

Thanks for your reply. After testing I found the reason causing a "damaged file" message.
I had imported an image in my file on the iPad. I deleted that layer and then saved as a copy and now it opens fine. I assume it's because the jpg image I imported is not embedded within the Affinity file and it results in a broken link, as in Adobe Illustrator.

Do you know if there's any ways that the image file gets embedded so I don't have to delete this jpg each time I want to work on desktop?

As a suggestion for future updates to the desktop app, it would be nice if it would let you open it anyway and just tell you that some files (image in this case) are missing. At least you're not blocked in the process, and you're free to fix it or not. I think Adobe handles that quite nicely.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now