Jump to content
Ollieillo

‘Add’ tool stuck on loading screen

Recommended Posts

Hi I’m working on an illustration and trying to turn all the lines into shapes so I can colour them, I’m doing as I usually would and expanding the stroke > then in geometry tools click add but when I do that the add loading screen appears and then gets stuck on that screen, it works fine on some expanded shapes when adding them others it doesn’t. I’m selecting only a small part of my illustration to do this too it’s not the whole illustration which would likely take time as it’s more complex, but surely it should be able to work on complex shapes too shouldn’t it? 

Look forward to your reply. 

Share this post


Link to post
Share on other sites

If you are prepared to attach the .afdesign file, someone else can test it for you too. :)


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

Hi DM1

I can’t upload it to a public forum as it’s part of commissioned work. Is there a way I can send via private message?

cheers

Ollie

Share this post


Link to post
Share on other sites

I understand. In that case, one of the mods should be along shortly. They have a private Dropbox and will be able to see if they can replicate the issue.


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

They usually check new bug reports so you shouldn’t need to repost.

What tool did you use to create the shapes?

 


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

I was using the pencil tool > selected expand stroke > selected multiple overlapping expanded shapes > then pressed add. I had a play around with it yesterday and it seems that when making the shapes a cluster of nodes can cause an issue, as when I remove nodes it works for adding some shapes together. Not sure if this is something the tea is aware of but it would be very helpful if this can be fixed. It’s taken hours to delete loads of nodes.

Share this post


Link to post
Share on other sites

Hopefully mods will get a copy of your file, replicate the fault and pass it onto devs for a fix. :)


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

Hi Ollieillo,

Sorry for the delay! If you could upload your file to our internal Dropbox account using the link below that would be great!

https://www.dropbox.com/request/oxiYovX1ebPuN7c0h4p9

There is a known issue that this can get stuck on complicated Geometry, however files are always useful for development when fixing the issue and also for testing it so that would be very useful!

Thanks

Share this post


Link to post
Share on other sites

Hi Sean, 

thats ok, thanks for getting back to me. I’ve been playing around with it and deleting many many nodes and I seem to of finally been able to get the lines to join, and this is the latest version I have, are you able to go back in the history of the document to see before it was all joined together? Cheers

Ollie 

Share this post


Link to post
Share on other sites
18 hours ago, Ollieillo said:

Hi Sean, 

thats ok, thanks for getting back to me. I’ve been playing around with it and deleting many many nodes and I seem to of finally been able to get the lines to join, and this is the latest version I have, are you able to go back in the history of the document to see before it was all joined together? Cheers

Ollie 

Thanks for the file! Unfortunately unless you've enabled 'Save History With Document' on the file menu then the history is not stored after the file is closed down. I've downloaded your file, but unfortunately the history is not there.

Share this post


Link to post
Share on other sites

Hi Sean, ah ok didn’t know I had to enable history of a document, how do I do that? 

When I work on another piece with complex shapes I’ll send here for you to look at.

Also on a sort of separate note are there plans to improve the iCloud capabilities of the app? Having used many other apps that would automatically save a document to the cloud when going to the main menu it’s extremely frustrating to have to go into the little burger back icon and manually save documents to the cloud, especially if you aren’t on the device where it originated, then you can’t access the work at all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×