Jump to content
illusie

loading nik plugins: updating fonts...

Recommended Posts

hi,

in my affinity photo version 1.6.7. i use de nik plugin set. i'd wish more plugins would be compatible. i mentioned this long ago while testing earlier beta versions. but in this new beta i still can't get this done.

but my more important complaint is that now my installed (see attached screenshot) nik plugin filters don't work any longer. when i select a filter in menu/filters/plugins/nik collection i get the message 'Updating fonts...' (see attached second screenshot). the only thing i can do after that is to violantly force affinity photo to stop.

regards
jan van de ven

 

Schermafbeelding 2018-12-27 om 14.23.24.png

Schermafbeelding 2018-12-27 om 14.40.49.png

Share this post


Link to post
Share on other sites

Same problem here. Reinstalled the DxO version. No problem to get the Nik plugins on 1.6.7 but the 1.7 beta always hangs, "installing fonts," and requires a force quit to exit.

Share this post


Link to post
Share on other sites

Hi illusie

This is a known issue, bu unfortunately its something DXO needs to solve. As we are using a newer platform to build our app older things used in the nik plugins have changed. This will effect most apps that are built on the newer xcode 10 platform I'm afraid. DXO need to update the plugins to suit I'm afraid

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites
1 hour ago, Chris_K said:

unfortunately its something DXO needs to solve

well, thanks a lot, affinity-builders. i bought my nik collection before the software was sold to google. though i paid approx. 100 euro's for it, dxo does not give me free updates. and now i can't use my favorite plugins in combination with affinity photo any longer after the update. what about backwards compatibility?

Share this post


Link to post
Share on other sites
On 1/3/2019 at 11:42 AM, illusie said:

well, thanks a lot, affinity-builders. i bought my nik collection before the software was sold to google. though i paid approx. 100 euro's for it, dxo does not give me free updates. and now i can't use my favorite plugins in combination with affinity photo any longer after the update. what about backwards compatibility?

Hi illusie, as a workaround, you can use the NIK filters as standalone applications, I suppose. That's how I do it from the beginning. But I don't like plug-ins anyway, so I'm biased. 

Cheers, Puck


(iMac 2017, 16 GB RAM, Intel Iris Plus Graphics 640 1536 MB, MacOS 10.14.3)

Share this post


Link to post
Share on other sites
8 hours ago, Puck said:

Hi illusie, as a workaround, you can use the NIK filters as standalone applications, I suppose.

i know the workaround, puck. i often use the nik filters as plugins in adobe lightroom. but using them as plugins in affinity makes it possible to assign separate plugins to separate layers. and in affinity photo i can assign filters to (different) selections. i'd like to continue working like that in my workflow. but when the affinity software developers do not implement the use of the current version of the nik filters, it will be the end of my favorite workflow when the update will be released. do we have to accept it, to be deprived of functions we had?

Share this post


Link to post
Share on other sites
On 1/5/2019 at 11:37 PM, illusie said:

it will be the end of my favorite workflow when the update will be released. do we have to accept it, to be deprived of functions we had?

I see your problem, Illusie, and of course earlier functions should remain in the program, that's for sure! I think the developers still have a lot to do! But they can handle it, I'm sure. In the meantime I continue working with version 1.5.2 or 1.6.7

Cheers

Puck


(iMac 2017, 16 GB RAM, Intel Iris Plus Graphics 640 1536 MB, MacOS 10.14.3)

Share this post


Link to post
Share on other sites

I have been using the DxO Nik plugins with the 1.7 beta and they work fine. The Topaz plugins, including Topaz Studio also work fine. 

John


Windows 10, Affinity Photo 1.6.5.123 and Designer 1.6.5.123, (mainly Photo), now ex-Adobe CC

CPU: AMD A6-3670. RAM: 16 GB DDR3 @ 666MHz, Graphics: 2047MB NVIDIA GeForce GT 630

Share this post


Link to post
Share on other sites

i have the google nik version. payed 112 euro for it, a few years ago. bought the packages before google decided to give it away for free. i'm afraid i will have to spend another 69 euro since serif says it's something dxo has to fix.

Share this post


Link to post
Share on other sites
3 hours ago, John Rostron said:

I have been using the DxO Nik plugins with the 1.7 beta and they work fine. The Topaz plugins, including Topaz Studio also work fine. 

John

Currently most of the Nik Collection by DxO doesn't work on Affinity Photo Customer Beta 1.7 on Mac, only on Windows.

Share this post


Link to post
Share on other sites

Recently seen, this official NIK DxO compatibility overview ...

OfficialNik-DXOCompatibility.png.a55532986e05c56146d52989e816535c.png

 


☛ Affinity Designer 1.6.1 ◆ Affinity Photo 1.6.7 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites
20 minutes ago, v_kyr said:

Recently seen, this official NIK DxO compatibility overview ...

thanks. your overview-graphic made me try again. and to my surprise: it works. i tried it just after i installed the new affinity photo beta version (1.7.0.109). but i think it's not the new beta that makes the difference. i presume it's the new version of osx i installed last week (macos mojave version 10.14.3).

problem solved.

thanks everyone for your comments.

Share this post


Link to post
Share on other sites

I don't see the relevance of the table above since it doesn't list the compatibility with Affinity apps nor with the latest version of macOS 10.14.

Currently:

Google Nik Collection (1.2.11)
MACINTOSH

  • Is compatible with Affinity Photo 1.6.7 (retail) - (with a few issues)
  • Some plugins are NOT compatible with Affinity Photo Customer Beta 1.7.0.109 (Updating fonts error - requires force quit): HDR Efex Pro, Analog Efex Pro 2, Colour Efex Pro 4, Silver Efex Pro 2. The rest work (Dfine 2, Sharpener, Viveza 2)

WINDOWS

  • Is compatible with Affinity Photo 1.6.7 (retail)  - (with a few issues)
  • Is compatible with Affinity Photo Customer Beta 1.7.0.209 (with a few issues)

---------------------

Nik Collection by DxO (1.2.18)

MACINTOSH

  • Is compatible with Affinity Photo 1.6.7 (retail)  - (with a few issues)
  • Some plugins are NOT compatible with Affinity Photo Customer Beta 1.7.0.109 (Updating fonts error - requires force quit): HDR Efex Pro, Analog Efex Pro 2, Colour Efex Pro 4, Silver Efex Pro 2. The rest work (Dfine 2, Sharpener, Viveza 2)

WINDOWS

  • Is compatible with Affinity Photo 1.6.7 (retail)  - (with a few issues)
  • Is compatible with Affinity Photo Customer Beta 1.7.0.209  - (with a few issues)

 

Resuming,

- on Macintosh, only a few plugins of the Google and DxO versions of the Nik Plugins run on Affinity Photo 1.7 Customer Beta (Dfine 2, Sharpener, Viveza 2) - the rest don't work. Both versions run on the current retail version (1.6) with a few minor issues.

- on Windows both Google and the DxO versions of the Nik Plugins run both on Affinity Photo 1.7 Customer Beta and the current retail version (1.6).

 

Share this post


Link to post
Share on other sites
1 hour ago, MEB said:

Nik Collection by DxO (1.2.18)

MACINTOSH

  • Is compatible with Affinity Photo 1.6.7 (retail)  - (with a few issues)
  • Some plugins are NOT compatible with Affinity Photo Customer Beta 1.7.0.109 (Updating fonts error - requires force quit): HDR Efex Pro, Analog Efex Pro 2, Colour Efex Pro 4, Silver Efex Pro 2. The rest work (Dfine 2, Sharpener, Viveza 2)

it seems i made a stupid mistake. i thought i was sure to be running the latest beta version of affinity photo, but i think it must have been my regular program. it's as MEB says: only dfine, viveza and both sharpeners work. and for instance my favorite silver efex pro doesn't.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×