Jump to content
Stanearl

Tiff Import problems in affinity photo

Recommended Posts

I don’t know if y’all recent updated messed things up! But I’m having problems import my photos. What’s it doing no is taking my photo into the develop persona, and my photo doesn’t show up, it’s just a black screen with the metadata in the top tab! Once I click apply it just restart the app! I’ve already uninstalled and reinstalled the app still does the same thing! This is the first time dealing with this on a import I’ve never had this problem before I’ve been working in affinity photo for almost 2 years now! The file I’ve always imported in are TIFF. Thanks

AA0A3114-EDC7-4FA5-A251-3CE9094B1EF9.png

Share this post


Link to post
Share on other sites

Same problem, but on RAW files from my Canon 5D MKIII that I was previously able to import.

It’s broken on all three import methods:
Open from Photos (Develop Persona shows blank screen and crashes as described above).
Drag and drop from Files App: Same result when it opens Develop Persona,
Create new document (or open an existing one) and Place Image: No image appears when you start dragging to place. Even the blue box that sizes the image has disappeared.
JPG is still working, some small TIFF files still work (guys please try that out?) and at least one smaller RAW file samples I found online was still able to load - however the file size was smaller than usual from what I could tell. So it looks like a memory issue. 

Did anyone else find their iPAD was unstable after a while after using Affinity? I think it did settle a bit recently but I was having occasional reboots and touch screen failure which required hard resets to fix. Since I turned on the ‘Cache screen updates (uses more memory)’ option this has been better, or that could be coincidence and the result of an update / bug fix since then. Anyway that’s an aside. The main point here is that RAW and TIFF import for normal sized files seems to be broken, most likely due to not enough memory being available.

Affinity team - I’ve added a video below to show the bug in action. Please do let us know when you can get a fix out? I’d love to be editing my raw files on iPAD again soon..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×