Jump to content
fefrei

Adjustments lost during PDF export on iPad

Recommended Posts

I‘m having problems exporting designs that contain a masked invert to PDF (or SVG) on iPad. The attached file demonstrates the issue: It contains a light-gray rectangle, a large part of which is inverted by a masked invert adjustment placed above its layer. In the app, this results in a near-black area, as expected. This also works fine for rasterized exports, see the attached PNG image. However, when exporting to PDF, the invert adjustment is apparently lost, and I only see the light-gray rectangle. Is this a bug in Affinity Designer?

MWE.afdesign

MWE.png

MWE.pdf

Share this post


Link to post
Share on other sites

In Export PDF settings, under Rasterise, select Everything. 


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

Hi fefrei,

Unfortunately I don't believe PDF supports the Invert Adjustment which is why it doesn't appear. If you're doing vector work and relying on PDF or Vector output then it is advisable to avoid using adjustment layers otherwise you'll encounter issues such as this one.

Share this post


Link to post
Share on other sites

Hm, that is unfortunate. Doing vector work in Affinity Designer and trying to export it as vector graphics doesn't seem like a niche use case to me. It'd be nice if this would be supported better. (This would probably mean that Affinity Designer would have to cut the shapes and compute the new colors on export.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×