Jump to content
gordo

Still converts Black only to 4/C

Recommended Posts

Oops. I forgot to add about the drop shadow. 

Double-click on the swatch proxy in the Effects panel. Then switch to the cmyk sliders. You'll see it is a 4 color build. Change it to 100%k.

Share this post


Link to post
Share on other sites

Sorry, but I didn't use the swatches palette. I specified the text as 100% K. Your version appears identical to mine. And when I export yours as a PDF it also converts from 100K to 4/C and the same wrong profile is embedded.

I.e. There is no difference between your file and mine.

Share this post


Link to post
Share on other sites

Any of the PDF/X profiles should work and set the document intent to your GRACOL profile.

I have no idea what the PDF for Print profile is doing and I do not use it. If anything, it is broken as regards setting the intent at the document level. But the items are properly tagged.

Share this post


Link to post
Share on other sites

OK. The Export for Print is setting the blend space to RGB. That is likely the cause of the issue. This happens no matter if one sets the export color type to CMYK or not.

Mike

Share this post


Link to post
Share on other sites

Hi Gordo,

I noticed that the Filter Effects colour pop out was showing the sliders as being 0,0,0,100 for me, but the colour shown was actually Rich Black. If I slide the K slider down and then back to 100 and then export it goes out correctly. Could you check that for us please? It could just be the Filter Effects is incorrectly showing the wrong slider position!

Share this post


Link to post
Share on other sites
3 hours ago, Chris_K said:

The devs are working on some more fixes for K only PDF exports so hopefully this will be resolved within the next couple of builds

Cheers

Good, because it’s a show stopper if it’s not fixed. And just to be clear, this refers to a K only graphic in a CMYK document that’s exported as a PDF.

Share this post


Link to post
Share on other sites
1 hour ago, gordo said:

1.7.0.227 The black bug continues :-(

How about in the current beta 238? I also need this to work but have not had time to try in latest.


--------------------

iMac (Retina 5K, 27-inch, 2017) • Radeon Pro 580 8192 MB • macOS High Sierra

Share this post


Link to post
Share on other sites

There is support in Designer beta (since 1.7.0.231 on Windows) for a "K only" option when placing images into a CMYK document. I do not know if it would/will affect black text when exporting to PDF, or if it only affects embedded images. I do not see any mention of this in the Release Notes for Designer on Mac, but if it's on Windows it will presumably appear in Designer for Mac, too.

Whatever it does will presumably also make its way into Publisher (Windows and Mac) at some point, too, though it does not seem to be in Publisher beta for Windows yet.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites
34 minutes ago, nwhit said:

How about in the current beta 238? I also need this to work but have not had time to try in latest.

1.7.0.227  is the most current version (MAC OS) - downloaded it this morning and checked again just now and Affinity Publisher says I'm up to date. Maybe it's different on Windows?

Share this post


Link to post
Share on other sites
1 minute ago, gordo said:

1.7.0.227  is the most current version (MAC OS) - downloaded it this morning and checked again just now and Affinity says I'm up to date.

No, .238 is the most current, it simply may not be on auto-update yet. The new releases are always made available via the forums before being made available by other channels.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites
13 minutes ago, walt.farrell said:

No, .238 is the most current, it simply may not be on auto-update yet. The new releases are always made available via the forums before being made available by other channels.

Goofy.

I downloaded the .238 version and again, the black issue is still there :-(

Share this post


Link to post
Share on other sites
1 minute ago, gordo said:

I downloaded the .238 version and again, the black issue is still there :-(

As I said, the K Only support/option seems to currently be only in Designer, and possibly only in Designer for Windows. As Publisher clearly has the same issue, I expect we'll see that support in Publisher in an upcoming beta release, too.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.