Jump to content
Viktor Yurov

[By Design] Canvas. Drag to move bug.

Recommended Posts

Hello,

This is pretty old problem. I had still waited for a fix, but it seems it is a kind of rare one.
I use Affinity Photo v1.6.5.123 for Windows (bought in the Microsoft Store).
So... when I use Hand too to move canvas, everything works as a charm, but when I press Space button to activateу it fast, the canvas makes to be crazy.
It is worth noting, that I use Affinity Designer too, but there is not such problem.
I have made a short video to demonstrate it. I hope it will be useful and will help to resolve the problem.

https://youtu.be/B9GqQit6sDs

 

 

Share this post


Link to post
Share on other sites

Hi @GabrielM,

Thank you!

It works well in Designer in both personas. As for Photo, the problem is existing for all possible personas which is available in the program.

Here is my settings for Affinity Photo:

image.png.02db8650fe920fcf0d7ea0f3e406ee55.png

And for Designer:

image.png.af977c17d7617b20b466deb25eebe786.png

I also played around with the settings, but unfortunately it didn't give me a result.

 

Share this post


Link to post
Share on other sites

Let's try to reset the app first. 

You can reset your app back to its default settings by holding down the CTRL key while launching the app. When the Clear User Data window appears, click Select All and then Clear. The app will now open.
 
Be aware that resetting your app back to its default settings will lose any custom settings such as keyboard shortcuts and brushes etc. To backup such settings before resetting the app, please watch our Affinity - Exporting User Settings and Keyboard Shortcuts video.

Share this post


Link to post
Share on other sites

No, I am using it only on Windows locally. I need the remote desktop software for another task, which doesn't relate with Affinity soft at all. It just works in the background and creates such compatibility problem. As soon as I close it, Affinity Photo starts to work much better.

Share this post


Link to post
Share on other sites

Oh, I just tried again. And I faced with a few such crazy moments in canvas movements while TeamViewer was closed. But generally it works much stable then before. And then I had open TeamViewer again, and it still works normal... Then I checked it on my second computer, where the bug is existed. And I noticed that there is no activated TeamViewer at all. I started to close other programs. When I have closed Punto Switcher, Affinity Photo was stared to work better. I am not sure that the problem in Punto Switcher and now I am not sure that the problem in TeamViewer. I just sure that the problem is little bit deeped then I thought.
And yeah it is odd...

Share this post


Link to post
Share on other sites

Sound like a 3rd party software causing this. Please let us know if you find a definite cause for this as we would like to put it on our list. 

Any chance you can create a new user profile with no other software apart from Affinity and see if you can replicate it?  

Share this post


Link to post
Share on other sites

Now I sure it at 100%. I had try it multiple times on two computers.

The next use-case:

PuntoSwitcher is working -> Launch Affinity Photo -> Canvas is buggy -> Close PuntoSwitcher -> Canvas works fine -> Launch PuntoSwitcher againg -> Canvas is a little but buggy -> Close Affinity Photo and may try again, the result will be the same.

So if to launch the Photo without PuntoSwitcher or close Punto during Photo is working, everything will be fine.

But if to launch the Photo with working PuntoSwitcher or open PuntoSwitcher while Affinity Photo is working, then canvas will be crazy.

Something like that...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×