Jump to content

Recommended Posts

Hi noeltoddusa,

Can you link to the video you watched?  

Can't say this is something i've done before, but in theory i'd expect to be as simple as clicking File>Export and selecting SVG.  Hopefully the video will help or someone who has experience working with mo2 will be able to post the solution  :)  

Share this post


Link to post
Share on other sites

Maybe digging into fine details of this Final Cut plugin/rendering system would help you  :

https://www.motionvfx.com/mO2/Manual/index.html#svg-import

"   exporting all shapes as simple path objects in SVG 1.0 format should generate a proper result   "

When I export anything svg to a 3D app (which I've done a lot) I check it to be ultra basic. (as well as the SVG spec required by the app, you can see there is SVG 1.0). Besides checking all shapes are closed, no single dot  or isolated segment rubbish anywhere, fonts are converted to paths, avoid at all costs any rasterized effect and transparency. You don't need any kind of fill, I guess, but if any, just solid fills. If the issue is that the SVG exported version is too modern, you might want to use Inkscape as a converter ( inskcape.org ) and try the several versions of SVG (flat, standard, etc). Can't say more as I don't own Final Cut neither that plugin... But I'd typically be able to make it work (there's always a way, directly or through utilities)


Affinity Designer and Affinity Photo licenses, Windows 7, i7  860 (2009) 2.8 GHz,  8 GB RAM, GTX 1050 2 GB, HD 7200 RPM.  Wacom Intuos 4 XL.

Share this post


Link to post
Share on other sites

Welp - I will cross post this answer since it does seem there are people out there searching for answers 

 

I tried variable checkboxes in the export settings and found out a couple of things.

 

1) IF you have a Transparent background, it will make it a solid in the 3D rendering. 

2)  Adding a White background behind the "logo" will reverse the process and make it so it 3D's the logo and not punches it out. 

3 )In order to Show Logo, you'll need to check the checkbox HOLE in the first option.

As you'll see - the logo looks good (I took out the words as I was trying some stuff :)

 

Screen Shot 2019-02-22 at 4.03.23 PM.png

Screen Shot 2019-02-22 at 3.58.16 PM.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×