Jump to content
Framon

PDF Export problem

Recommended Posts

My language is French, sorry for my bad English... I try to explain my problem :

I open a PDF file with AfPub (30 pages, text only)

I add a blank page

I insert a title with "Artistic text tool"

I try to export in PDF format and I receive the message "An error occured....". Who can help me ?


Affinity Photo - Affinity Publisher - Windows 10

Share this post


Link to post
Share on other sites
3 hours ago, Framon said:

My language is French, sorry for my bad English... I try to explain my problem :

I open a PDF file with AfPub (30 pages, text only)

I add a blank page

I insert a title with "Artistic text tool"

I try to export in PDF format and I receive the message "An error occured....". Who can help me ?

Hello @Framon,

I tried to reproduce this with a PDF of my own (650 pages, text only except for one image).
I added one page at the beginning, inserted a one line title with the 'Artistic Text Tool' and exported. No error occured.

You'd have to provide a little more information:

  • What version of APub are you using.
  • Where do you add the blank page (at the beginning or at the end).
  • What font was used to create the title?
  • What is the source / the creating software of the PDF.
  • Can you by any chance post the PDF here in the forum so that others can try to replicate?
  • Did you save the PDF as a seperate file or did you try to overwrite the original file?

You see, there are many factors that can be the source and there may be even more of them :)

d.


Affinity Designer 1.7.3.481 (beta 1.8.0.486)   |   Affinity Photo 1.7.3.481 (beta 1.8.0.486)   |   Affinity Publisher 1.7.3.481 (beta 1.8.0.499)
Affinity Designer for iPad 1.7.0.7   |   Affinity Photo for iPad 1.6.8.77

Windows 10 (1809) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites

Hi Dominik, many thanks for trying to help me.

  • APub 1.7.0.206
  • At the beginning (first page)
  • I tried with different fonts
  • The source was created with PDF-Xchange Editor Plus
  • See attached file (original file was without the fist page)
  • I saved the PDF as separate file

Visites escales_Costa-Internet.pdf


Affinity Photo - Affinity Publisher - Windows 10

Share this post


Link to post
Share on other sites
51 minutes ago, Framon said:

Hi Dominik, many thanks for trying to help me.

  • APub 1.7.0.206
  • At the beginning (first page)
  • I tried with different fonts
  • The source was created with PDF-Xchange Editor Plus
  • See attached file (original file was without the fist page)
  • I saved the PDF as separate file

Visites escales_Costa-Internet.pdf

Hi @Framon,

thank you for the details and the PDF. I opened it, added a blank page before the first page and added an Artistic Text in it.

Export as PDF (presets 'PDF for export', 'PDF for print', 'PDF for web', 'PDF flatten' and 'PDF/X-3.2003') worked without a problem.

Did you by any chance save to an external drive or a network drive?

d.


Affinity Designer 1.7.3.481 (beta 1.8.0.486)   |   Affinity Photo 1.7.3.481 (beta 1.8.0.486)   |   Affinity Publisher 1.7.3.481 (beta 1.8.0.499)
Affinity Designer for iPad 1.7.0.7   |   Affinity Photo for iPad 1.6.8.77

Windows 10 (1809) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites

No, Dominik.

An other face of my problem : I open the PDF file with AfPub. I save it in afpub format. I open it and want to export in PDF in a other directory : same error message...

I tear my hair ...


Affinity Photo - Affinity Publisher - Windows 10

Share this post


Link to post
Share on other sites

Hi @Framon
I tried your file, and it seems to work on me. However, saving it as a PDF takes a relatively long time (3-4 minutes).


My Specs:
- Processor: AMD Phenom™ II X4 955 Processor 3.20 GHz- RAM: 8 GB
- Graphics card: NVIDIA GeForce GTS 250
- Monitor: SyncMaster F2380 (resolution 1920x1080)
- Operating system: Windows 10 Pro (1803) / 64 bit

Share this post


Link to post
Share on other sites
47 minutes ago, Framon said:

No, Dominik.

An other face of my problem : I open the PDF file with AfPub. I save it in afpub format. I open it and want to export in PDF in a other directory : same error message...

I tear my hair ...

I'm not sure if these instructions will still work, or work for Publisher, but they have worked for users of Designer on Windows in the past. If they work you'll get a log file that may provide more information about the problem. You could post the log file here if you need help interpreting it.

 


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.499 Beta

Share this post


Link to post
Share on other sites

I tried many times to resolve my problem but I always receive same message.

I'll try the solution proposed by walt.farrell.

Thank you all.


Affinity Photo - Affinity Publisher - Windows 10

Share this post


Link to post
Share on other sites
2 hours ago, Framon said:

I tried many times to resolve my problem but I always receive same message.

I'll try the solution proposed by walt.farrell.

Thank you all.

Hello @Framon,

I'm sorry that the problem is not solved yet. At the moment I am out of ideas but walt.farrell's tip could shed some light to the source of the problem.

I haven't asked on which platform you are: MacOS or Windows? Windows which version. There must be some imcompatibility with your system that others don't have.

d.


Affinity Designer 1.7.3.481 (beta 1.8.0.486)   |   Affinity Photo 1.7.3.481 (beta 1.8.0.486)   |   Affinity Publisher 1.7.3.481 (beta 1.8.0.499)
Affinity Designer for iPad 1.7.0.7   |   Affinity Photo for iPad 1.6.8.77

Windows 10 (1809) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites

Hello Dominik,

I updated my signature. You will be able to see my O.S.

I tried with other PDF files. When I open PDF file with AfPub, save it in afpub format, open it and want to save it again in PDF format, I receive immediately the same message.

No time today for testing the walt.farrell's tip. Thanks again to all.


Affinity Photo - Affinity Publisher - Windows 10

Share this post


Link to post
Share on other sites

Bonjour Framon, j'ai répété les mêmes opérations que vous décrivez avec différents fichiers PDF et je n'ai aucun problème. Le problème découle sans doute d'une erreur d'accès au disque ou fichiers.

Hi Framon, I did the exact same steps that you describe, using different PDF files, and I don't have any problem opening and saving them. The problem looks more as a file or disk acces than a bug in Publisher.


Window 10 - 16 Gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060

Share this post


Link to post
Share on other sites

The most common problem that gives that error, if I remember correctly from the forum posts I've read, is an issue with some specific font that the user has installed. Removing or fixing that font has fixed the problem for several other users with that problem.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.499 Beta

Share this post


Link to post
Share on other sites

YES, walt.farrel !!! You're right !

I've uninstalled my last downloaded fonts and now, PDF Export works perfectly. Thank you so much for your help. :D

Merci aussi à AlainP de la Belle Province. Danke an Dominik für Ihren Rat.

For your information, the problematic font was "INDOCHIN_0.TTF".


Affinity Photo - Affinity Publisher - Windows 10

Share this post


Link to post
Share on other sites
12 hours ago, walt.farrell said:

The most common problem that gives that error, if I remember correctly from the forum posts I've read, is an issue with some specific font that the user has installed. Removing or fixing that font has fixed the problem for several other users with that problem.

Do you know whether this is a single font, or whether everyone has other fonts to blame?
Perhaps also the long processing time is a reason (see my post above).


My Specs:
- Processor: AMD Phenom™ II X4 955 Processor 3.20 GHz- RAM: 8 GB
- Graphics card: NVIDIA GeForce GTS 250
- Monitor: SyncMaster F2380 (resolution 1920x1080)
- Operating system: Windows 10 Pro (1803) / 64 bit

Share this post


Link to post
Share on other sites

I cannot say more. My problematic font was one I have downloaded from an Internet site. In my opinion, other fonts are in the case.

As I writed above, when I encountered the problem, it was immediately after choosing the directory to save the export file.


Affinity Photo - Affinity Publisher - Windows 10

Share this post


Link to post
Share on other sites
3 hours ago, Michail said:

Do you know whether this is a single font, or whether everyone has other fonts to blame?
Perhaps also the long processing time is a reason (see my post above).

I think I've seen a variety of fonts involved. I doubt it would explain a long export time; that's probably based on the complexity of the file (layers, live filters, etc.) in most cases.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.499 Beta

Share this post


Link to post
Share on other sites

 

7 minutes ago, walt.farrell said:

that's probably based on the complexity of the file (layers, live filters, etc.) in most cases.

You're probably right... again... :)


Affinity Photo - Affinity Publisher - Windows 10

Share this post


Link to post
Share on other sites

For what it's worth, I had problems with creating PDF files if I was using a proprietary font that required a license to use, or where the license was restricted. Sometimes the license can not be found, even when it's there. Can't remember how I did this, but I was able to list all the fonts installed in Windows showing whether or not it was proprietary. Once I stopped using these fonts, I had no more problems.

Share this post


Link to post
Share on other sites

Hello ToOldForThis,

Thank you for your advice. I think I found how to list the fonts with the characteristics :

Directory C:\Windows\Fonts (View details). Example in French version :

 

Polices.jpg


Affinity Photo - Affinity Publisher - Windows 10

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.