Jump to content
="Leo"

Affinity Designer, Export Persona: Wrong Size, Unable to change

Recommended Posts

Hello, dear Affinity Team,
this is driving me nuts right now. These are simple graphics, but the slices won't be in the correct size. There are no Shadows, no hidden elements etc.

I hope that this will be fixed ASAP,

Have a nice day!

________________

System:

Windows 10 Pro, v1803, Build 17134.471 
Affinity Designer - v1.6.5.123 Stable

Share this post


Link to post
Share on other sites

It would help to have your .afdesign file (with slices defined) so we can see what is happening, rather than having to watch a video.

And it would help to have a description of what size you expected and what size you got.

However, for a start, you need to be sure that the X and Y coordinates of each of your artboards have integer values. If your X or Y coordinate, for example, is at something like 10.2 px rather than 10px your exported slice will be 1px bigger than you wanted.

You may also need to ensure that the dimensions are also integer pixel values, e.g.,  width is 100px rather than 100.2px.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.815 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.815 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.798 Beta.

Share this post


Link to post
Share on other sites
1 hour ago, walt.farrell said:

It would help to have your .afdesign file (with slices defined) so we can see what is happening, rather than having to watch a video.

And it would help to have a description of what size you expected and what size you got.

However, for a start, you need to be sure that the X and Y coordinates of each of your artboards have integer values. If your X or Y coordinate, for example, is at something like 10.2 px rather than 10px your exported slice will be 1px bigger than you wanted.

You may also need to ensure that the dimensions are also integer pixel values, e.g.,  width is 100px rather than 100.2px.

the coordinates have integer values, I just rescaled everything (artboard, content) to have integer values and the slice borders are still horrifyingly inaccurate.


surge_reskin_export_problem.thumb.PNG.0e72cb63462c81d6085c0d1c9ce47b20.PNG

surge_bmp00153.afdesign

Share this post


Link to post
Share on other sites

Hi ="Leo",
Welcome to Affinity Forums :)
Neither the artboard nor the grouped objects have integer values. Check the screen capture below - notice the values in the Transform panel - you have to fix the decimal parts both for the X, Y coordinates and width/height (in this particular case - the purple one - the Y coordinates are correct/integer values):

screen_capture.thumb.png.894968b89819719d56f2d7940beafea9.png

Share this post


Link to post
Share on other sites

huh, that's really strange, because to me it looks like it is. Is there any place where I can activate more precise value display?surge_reskin_export_problem_2.thumb.PNG.af93c958e4f3855436cb693539403980.PNG

 

EDIT: found it in the settings. Now I'm seeing what you are seeing.

Share this post


Link to post
Share on other sites

Okay, thanks a lot for your help! 
I want to note that I completely retyped everything (with only 1 decimal place) in my 2nd post though, so that means it didn't adjust the decimal places that weren't displayed to me. This is a little bit confusing...

Have a nice day!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.