Jump to content
AdamW

Affinity Publisher Public Beta - 1.7.0.206

Recommended Posts

Status: Public Beta
Purpose: Stability and General Testing
Requirements: 64 Bit Win 7 SP1 / Win 8 / Win 10 

Hi,

We are pleased to announce Affinity Publisher build 206 is now available on auto-update and as a manual download from the link above.

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity where you may be adversely affected by the application failing, including the total loss of any documents. 

We hope you enjoy the product, and as always, if you've got any problems installing or running up, please don't hesitate to post in this thread.

Any problems actually using this version please make a new topic in this forum and we'll get back to you as soon as we can. Please feel free to leave general suggestions and comments in the Discussion Forum. Many thanks for your continued feedback.

Short of major catastrophe this will be our last update until January, so I would like take this opportunity to wish you a Happy Holiday Season and a Happy New Year. Many thanks for your continued feedback.

--

Main View
Some common tools missing shortcuts
Fixed issue setting ruler origin for spreads other than first
Fixed Pen Tool not initially snapping to grid when document opened
Fixed Rotation Centre not snapping to guides
Fixed issue with panels (e.g. Styles) resizing content when scheme changes
(Mac) Fixed special case of Ctrl+V failing as a shortcut
(Win) Basic Grid fails to show 'Spacing' and 'Divisions' entry boxes on Grid and Axis Manager

Loading / Saving
Fixed failure to save if HEIC file is used in document
The term 'Embedded Document' is replace with 'Linked Document' in the UI when appropriate
Fix for Picture Frame Properties defaults not saving correctly

Pages and Document Setup
Added option to switch an existing Master Spread between Single and Facing

Import / Export / Print
Fix for PDFs with different DPI to document DPI importing at the wrong size
(Win) Print max copies increased to 9999 
Pre-print check warns about overflow when text is hidden.
Fix for Crop Marks appearing in document area on Print

Text
Fixed Drag Drop text from Finder / Explorer to drop into existing frame if available
Capitalisation not being set when text frame is selected
Fixed Drop Caps alignment when using Baseline Grid
Fixed Baseline Grid alignment for second page of vertical spread
Fix for linked text frames flipping link order to match z-order when cloned
(Win) Fixed limits on Paragraph Justification settings
(Win) Fix for a new 'Based on' text style not being set up correctly from its base style
Fix for 'No Style' not removing Lists, Drop Caps, Initial Words attributes
Fix for 'Decrease List Level' not always working correctly
(Mac)Removed recently used fonts erroneously placed at top of 'All' section
Fix for Optical Alignment with quotations causing Artistic Text to jump horizontally

Find and Replace
(Mac) Fix for entering comma into Find Field
Fixed tabbing issues in Find and Replace Panel
Implemented better 'Replace All' behaviour

Other Panels
Fixed Assets subcategory order not being remembered after restart
Fix for crash when adding to a Symbol after deleting all the children in a detached instance
Double Click to add Glyph in Glyph Browser could crash if tool was not active
(Win) Fixed History scrolling with the mouse wheel removed highlight

Resource Manager
Different images are grouped as the same in Resource Manager when opening PDF
Fixed Colour Profile in Resource Manager not updating when image replaced
---

Earlier Release Notes Beta 192

Share this post


Link to post
Share on other sites

Installation on Win10 worked and all my documents still open. :)


Windows 10 Pro x64 (1903). Intel Core i7-9700K @ 3.60GHz, 32 GB memory, NVidia GTX 780
Affinity Photo 1.7.1.404, Affinity Designer 1.7.1.404, Affinity Publisher 1.7.1.404

Share this post


Link to post
Share on other sites

I did something unusual (or silly, or stupid, or ...) for the install of .206.

I downloaded the new installer.

I then used the Windows Task Manager to kill the instance of .192 that was running, rather than closing it normally. It had 6 files open at the time.

I then installed .206, which installed properly.

When I run .206 it tells me there were 6 files open, and offers to restore them. When I tell it to do so, all six files are briefly visible on the screen as they open, but before the UI finishes initializing (i.e.,  no tabs are drawn, Tools are not active, etc.) Publisher hangs.

None of the usual Windows controls (minimize, restore, close) work. If Publisher is behind another window, it won't surface if I click on its workspace. However, I can close it by using the close button on its icon on the Windows taskbar.

Before I clear this situation, are you interested in any diagnostic data about it, and if so, what should I try to gather?


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.2.458 Beta

Share this post


Link to post
Share on other sites
13 hours ago, walt.farrell said:

Before I clear this situation, are you interested in any diagnostic data about it, and if so, what should I try to gather?

Hi Walt,

Thanks for the offer. If you have cleared it, fair enough, but ideally we’d want the contents of your autosave directory which you would find here - %AppData%\Affinity\Publisher Beta\1.0\autosave. I think that’s about right, not best placed to double check right now, unfortunately! But we’d also need your original documents too as the autosave files are incremental changes from these.

Note: I've split the rest of this discussion to here.

Share this post


Link to post
Share on other sites

Thank you guys for this new beta. Installation was working well, but i wondered that my PC made a restart and updates while the installation was running. I think it was a coincidence that this happend. After the restart the programm runs without problems and thanks for fixing my issue. Snapping from rotation centre to the guides works well now.
Thumbs up :)


Have a nice day.
Ich wünsche einen schönen Tag.

Share this post


Link to post
Share on other sites

Using Windows 10 Build 1809 I used this build and the previous one to work on a photobook.
It contains about 90 images on 12 pages so far beside text and lots of layer effects.

I would like to thank the team for the beta and give the feedback that beside some usability
problems this software works really well and is pretty stable on my system.

Exporting the document to a 400 MB PDF and re-importing that again does no harm.

I just encountered only one crash as I batch changed the ICC profile of my linked images.
Updating those 90 "Modified" images in the Resource Manager all at once resulted in a crash.

For regular working with the software for about 10 hours ore more by now there were no stability issues at all.

I really like what you're doing and keep up the good work. I definitely will buy Publisher on release.


Windows 10 Pro x64 (1903). Intel Core i7-9700K @ 3.60GHz, 32 GB memory, NVidia GTX 780
Affinity Photo 1.7.1.404, Affinity Designer 1.7.1.404, Affinity Publisher 1.7.1.404

Share this post


Link to post
Share on other sites

Thanks for this update, and the fast fix of the bugs I've reported. Impressive !

I really hope we'll have a final version (or an initial commercial version), in my mother language :-)

And, thanks for the T-Shirt too, i've order one to support and promote affinity products at work. But for this season a sweatshirt would have been better :-D

 

Share this post


Link to post
Share on other sites

Windows 7...

I downloaded the 1.7.0.206 version (twice) and they both failed to install over a previous beta version.  I am now left with a folder to which I do not even have Administrator access in C\Program Files\Affinity.  I cannot delete this folder.

I cannot uninstall the old version as it does not now appear in the Control Panel/Programs listing.

What to do?

Share this post


Link to post
Share on other sites

Is auto-hyphenation fully supported? I'm on 206 but when I tick Use auto-hyphenation in the paragraph tab for my currently selected text frame, nothing happens. 

Or maybe I'm misunderstanding the feature.

image.png.3b6ab49e54e3d814bd4a4cc96b402853.png

Should it not automatically insert a hyphen between some and thing in that example?

Share this post


Link to post
Share on other sites
56 minutes ago, Srekel said:

Is auto-hyphenation fully supported? I'm on 206 but when I tick Use auto-hyphenation in the paragraph tab for my currently selected text frame, nothing happens. 

Or maybe I'm misunderstanding the feature.

image.png.3b6ab49e54e3d814bd4a4cc96b402853.png

Should it not automatically insert a hyphen between some and thing in that example?

It would be better to ask your question in a separate topic. But yes, hyphenation is supported, as long as you've specified all the settings for language and hyphenation correctly in the Character and Paragraph panels, or in the text style that you're using. If you need help I'd recommend posting a topic in the Publisher Discussion and Suggestions forum.


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.2.458 Beta

Share this post


Link to post
Share on other sites

Thanks Walt! Sorry, I asked here because one of the recent patch notes mentioned fixing something with the feature.

Changing the language on the Base text style and then setting autohyphenate to true on the Body style worked. :) I tried finding a way to set the language for the document somewhere else but it seems that's the only place you can set the default language.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×