Jump to content
MatteoF

Bug while rasterizing a vector masks containing holes

Recommended Posts

Hi, I just got Affinity Designer and I really love it.

But, exporting one artwork as a raster, I’ve encountered a strange behavior that I believe is a bug.

I have a vector shape, called “Dark Plastic” used as a mask for a raster layer. This vector shape contains some holes (circled in red in the first attached screenshot). When I try to export the whole work as a png or jpeg file, or simply I try to rasterize that layer, those holes disappear, as shown in the second attached screenshot. All other layers seem to work just fine.

Thank you.

 

B4335F69-CDDE-427C-94FD-951060609378.jpeg

9CE8D739-EE10-4663-A723-E4F99801DBB6.jpeg

Share this post


Link to post
Share on other sites

Thank you. Sorry for the delayed reply. We have logged it with our developers for further investigations. This only seems to affect the iPad and not the Desktop builds. 

Share this post


Link to post
Share on other sites

No worries. I have found a workaround for this specific case, so, as I am concerned, there is no rush to find a solution. I just wanted to report it for giving you the chance of improving the app.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×