Jump to content

Recommended Posts

I was having issues this morning with Auto-Correct. It seems that the Beta (192) still only ships with English UK, which is fine. I created a new text box and added text to test Auto-Correct to find it did not work. A search of the forum indicated that I need to change the language in the Character tool. It was set to EN/CA which is what I use, and probably set somewhere. I highlighted the test paragraph and changed the language to English UK. I entered in some items like (C), (a), -- (two dashes), (tm), to see if they would change. The first three changed as expected, but when I typed in (tm) APub stopped responding. I had to force it closed.

Share this post


Link to post
Share on other sites

Hi TooOldForThis

Auto correct needs the entries defining for each language so if you manually add another dictionary language then you would also need to manually add your own auto correct entries but this can be done in the auto correct section of the preferences. 

I;m not getting any crashes for (TM) in UK English though it auo corrects for me without issue. was the crash just the once or does it crash every time you try do do this?

Thanks


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Chris,

I tried this again this morning. APub opened offering an unsaved file from the crash, which I declined--instead opening the original file. I selected the empty text box, changed the language to English UK, and typed in some text along with text that should be auto-corrected. The text style was [No Style]. All the changes took place EXCEPT for double-dash that should have changed to an em-dash. Just to be sure I got it right, I edited the Auto-Correct preferences to ensure that a double-dash converted to em-dash. I also added a triple-dash to convert to an en-dash for good measure. I went back to the text box to add more text. This is when I noticed a strange situation: if the auto-correct text is NOT PRECEDED AND FOLLOWED BY A SPACE, the auto-correct does not work. For example " (a)," does not change to "@" but " (a) " does. It's the same for em-dash and en-dash: "text--text" will not change the double-dash to an em-dash (although it does here) but " -- " does. Same for en-dash. Since both em-dash and en-dash are usually used as a connector butted up against a word on either side, it would never change. No crash this morning, BTW.

I also noticed that when I changed the text style to Body Novel (one of my own), no auto-correct took place. I had to go back to the Base Novel group text style to change the language there to English UK from [No Change]. Since both the paragraph style [No Style] and character style [No Style] cannot be changed, should they not be using the default language set in preferences? Similarly, if a new style is created, should it not be automatically set to the default language unless specifically changed? Otherwise, it can be very confusing for the user, as in my case.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×