Jump to content
veepy

Bugs in the Search feature of Affinity Photo Help

Recommended Posts

I am using Mac OS Mojave Version 10.14.1 to run Affinity Photo Version 1.6.7. When I open the Affinity Photo Help window and type in a search term that I know is available in the Help documents, the search usually says no results. I even watched the Affinity Photo - Accessing Help video and repeated the exact search used and still was told no results. I believe this must be a bug. I wish this feature worked correctly. Can anyone speak to this issue?

Affinity Photo Help.pdf

Share this post


Link to post
Share on other sites

Welcome to the forum veepy :)

This is a known issue with our help and Mojave. We've tested the latest beta version of Mojave ( 10.14.2 ) and the help is working fine. Until Apple release Mojave 10.14.2 you can use the online help and its search feature. https://affinity.help/photo/English.lproj/index.html

Hope that helps!

Leigh

Share this post


Link to post
Share on other sites

Hi - as a brand-new user of Affinity, I installed it (purchased from Apple App Store) on MacOS Mojave 10.14.2, and help is non-functional.

When I search for a topic in the Help menu inside Affinity, the help window shows up blank. If I search again using the same string in the Search box inside Help, a list of topic headings actually show up in the Help window. But clicking on any of those topic headings once again results in a blank help window. So, I can see the topics exist, but cannot display any of the actual help content.

It looks like the promise of MacOS 10.14.2 fixing this issue has not been realized.

Share this post


Link to post
Share on other sites
18 hours ago, CasualUser said:

Hi - as a brand-new user of Affinity, I installed it (purchased from Apple App Store) on MacOS Mojave 10.14.2, and help is non-functional.

When I search for a topic in the Help menu inside Affinity, the help window shows up blank. If I search again using the same string in the Search box inside Help, a list of topic headings actually show up in the Help window. But clicking on any of those topic headings once again results in a blank help window. So, I can see the topics exist, but cannot display any of the actual help content.

It looks like the promise of MacOS 10.14.2 fixing this issue has not been realized.

I'm now getting the search results showing in macOS Mojave 10.14.2 but when clicking the topic's link, i'm taken back to the Affinity help home page. I'm also getting this in the beta verison too. I will log this with the developers.

Thanks for letting us know.

Share this post


Link to post
Share on other sites

The in-app Help system for both Photo and designer is broken. It does not link to any topic when the help link is clicked.

Running macOS 10.14.2 (Mojave), AD v1.6.1, AP v1.6.7

Example: (Here using Designer, but the same set of bugs are in Photo.)

From the app Help menu, type a search term. Then click on one of the "orange question mark" results (attachment APD Help Bug 1).

The help window opens to a blank window (attachment APD Help Bug 2).

If you enter a search term in the blank window, an abbreviated list of topics shows (attachment APD Help Bug 3), but if you click on any of the topics, it throws you back to the blank screen from step 2.

Basically, you cannot search the in-app help. All search attempts take you to a screen like attachment APD Help Bug 3, but clicking on any result will take you to a blank window or to the Help main page (the latter if the search was initiated from Help --> Affinity Designer Help (or from Help --> Affinity Photo Help). Meaning time is wasted clicking through the table of contents hoping to find a match.

APD Help Bug 3.jpg

APD Help Bug 2.jpg

APD Help Bug 1.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×