Jump to content

Recommended Posts

I'm having a whale of a time trying to figure out a problem and would greatly appreciate it if someone could help me figure out and correct a problem with the attached AF file, which is the logo for my business.

The problem: When I export this to a WMF file and then use that in another program to import the vector, I am getting an error that there are paths that are not closed, thus the import can't proceed. As you can see, there is text, a bitmap fill and a curved object (the thumbs up). I want to believe there is no problem with text and if there is I have no clue how to fix that (yes, I tried converting to curves and that doesn't, by itself, help the problem). So it comes down to the curved object. When I select it, I see 5 red square nodes and all the rest is blue square/circle nodes. I have tried to be self-resourceful, but I don't seem to find anything that helps me "close path(s)".

I've seen some suggestions here that there is a desire to have AF show indicators or provide a tool that would detect open paths. With this experience, I certainly would support that suggestion and would add that an intelligent option to close the path(s) would be helpful as well.

Although I am not a newbie, I am not a professional and only use what I need so this is getting deeper than my knowledge/capability. Again, if anyone can save the day for me I would appreciate it greatly and if you are in the SF Bay Area I'd be delighted to buy you a beer or wine!

PS: Is there a way to easily convert this to an AI file? I also have Corel Draw and can do it there, but I have to always try a ton of options with respect to version of AI and it always comes down to a trial-and-error exercise.

YIC Logo V2.afdesign

Share this post


Link to post
Share on other sites

KiheiMan, for some reason I can not open your file in the newest Designer Beta 1.7.0.2 it says there are features from an even later version.

But there is a Close Curve button in the Action group of AD, I don't know how many layer you have but if you select everything that is supposed to be closed and then click on this button it should force closed any that aren't.


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

I'm d-loading the beta now, but I can't open it. My current highest version, 1.6.4 also won't.

As gear maker says, use the close curve. The widget shows up on the context bar when you are in node tool mode.


iMac 27" Retina, c. 2015: OS X 10.11.5: 3.3 GHz I c-5: 32 Gb,  AMD Radeon R9 M290 2048 Mb

iPad 12.9" Retina, iOS 10, 512 Gb, Apple pencil

Huion WH1409 tablet

Share this post


Link to post
Share on other sites
Guest

Hello KiheiMan,

The red knots on the hand show where the curve is open. To check, pull the red knot slightly to reveal the knot below. 

To close the curve at such a place, take the node tool and draw a rectangle around the node (in fact there are two superposed nodes) and click on "Close Curves" in the context bar.

So I closed the curves, exported them to WMF and imported them into another vector software and word processing without any problems.

I am attaching the corrected file.

YIC Logo V2_corrigé.afdesign

Share this post


Link to post
Share on other sites

I'd like to point out that there is a clear warning from the devs NOT to use the Beta versions for production work.

If you do, you might run into trouble with your design at a later stage.

Share this post


Link to post
Share on other sites
Guest
3 minutes ago, catlover said:

I'd like to point out that there is a clear warning from the devs NOT to use the Beta versions for production work.

If you do, you might run into trouble with your design at a later stage.

@catlover, You're right, for my part I opened and modified in the current version (Windows).

Share this post


Link to post
Share on other sites
20 hours ago, Gear maker said:

KiheiMan, for some reason I can not open your file in the newest Designer Beta 1.7.0.2

Same here. Weirdly, when I try I first get a message about opening a non-beta "Release" version document, but when I click "Continue" I get the 'features from a later version' failure notice. (The same thing happens with the version uploaded by @reglico too.)

1584587857_laterversion.jpg.98af41d9127344d1f23deb07b76a3d69.jpg

I assume this is a bug in the Designer beta, unless there is a new release version I don't know about, which seems unlikely.


Affinity Photo 1.8.4, Affinity Designer 1.8.4, Affinity Publisher 1.8.4;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 40GB RAM; macOS 10.15.6
Affinity Photo 
1.8.4.186 & Affinity Designer 1.8.4.4 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.0.1

Share this post


Link to post
Share on other sites

Hi KiheiMan,
Welcome to Affinity Forums :)
The three independent bottom holes/shapea that represent the fingers are opened in the Thumbs Up Outline layer. To quickly fix this, select the Thumbs Up Outline layer, change to the Node Tool, draw a marquee around the whole hand (selecting all hand nodes) and click the Close curve button (second icon from left to right) in the Action section in the context toolbar.

Share this post


Link to post
Share on other sites
Guest

Hello MEB,

Interesting to see that only the nodes concerned remain selected after that, thanks for the tip.

 

Share this post


Link to post
Share on other sites

@MEB, @reglico, or whomever:

Is there any explanation for the two notices I got when I tried to open either version of the file, as shown in my earlier post? It can't be a "Release version" file that includes later features than the current beta ... can it? O.o


Affinity Photo 1.8.4, Affinity Designer 1.8.4, Affinity Publisher 1.8.4;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 40GB RAM; macOS 10.15.6
Affinity Photo 
1.8.4.186 & Affinity Designer 1.8.4.4 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.0.1

Share this post


Link to post
Share on other sites
Guest

Hello R C-R,

It would not be logical for a release version to contain features subsequent to the next Beta.

Since I was able to open the file with the release version of windows, it would make sense if it were a file created in the release version, maybe Mac. It would be interesting to know if Mac users have opened the file, and with which version of AD.

If the message only appears with the Beta (Mac) it must be a bug on this version.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.