Jump to content
TonyO

Tool/App Settings Not Remembered Between Sessions (Designer)

Recommended Posts

Not sure if this is a bug or intentional, but every time I open a document or start a new session, lots of tool settings are forgotten that usually remain consistent on the desktop app even after restarting the application.

Examples being:

"••• > Canvas > Clip To Canvas" needs to be activated every time i open the same document (usually saved per document).

Pencil Tool - forgets almost all settings, especially stabilizer prefs and needs to be reset every time i start a new session

Brush pallet - forgets Cap, Join, Align settings when the app is reopened, i just usually set and forget these since i always use certain ones. 

I'm sure there are others, but these stand out to me. On the desktop app i usually just set and forget these prefs, but on the ipad app they always need to be reset every time i start a new session. 

** I've heard it noted that the new ipads are experiencing bugs, i am on the 2018 12.9" ipad pro if this makes any difference

Share this post


Link to post
Share on other sites

Hi TonyO :)

Thanks for your report!

36 minutes ago, TonyO said:

"••• > Canvas > Clip To Canvas" needs to be activated every time i open the same document (usually saved per document).

This has been reported previously and is with our devs to be fixed currently.

39 minutes ago, TonyO said:

 Pencil Tool - forgets almost all settings, especially stabilizer prefs and needs to be reset every time i start a new session

I can't replicate this currently, I note that the controller settings aren't retained when returning to the home screen of the app and then back into the document, however I closed the app entirely and then relaunched it. My stroke size, colour and stabiliser settings were retained. If possible could you provide a screen recording of this?

44 minutes ago, TonyO said:

Brush pallet - forgets Cap, Join, Align settings when the app is reopened, i just usually set and forget these since i always use certain ones.

I'm also seeing the same results as above and these settings aren't being reset for me. Again a screen recording of this would be very useful.

I'm using a 1st generation iPad Pro 12.9" here, although there shouldn't be a difference here.

Share this post


Link to post
Share on other sites

I'm testing again now and it seems to be working OK but im just doing quick closes and reopens to the app. This morning when i opened the app for the first time after 10 or so hours of inactivity and having the app closed, i had to reset the settings above when I started working again (and i never turn off the rope stabilizer, so that struck me as odd and it resets itself back to 35px, i usually keep it around 15).

I'll document exactly how i use the app for the next couple days or so and report the circumstances under when these settings reset again. All i know is i have had to turn on the rope stabilizer on the pencil and set it to something other than 35px quite a few times already in my few days of using the app, it's somehow resetting itself (same with the stroke caps, i never use rounded caps, and i keep having to switch them back). 

Perhaps a quick close and reopen leaves parts of the app active for an amount of time before clearing parts of the memory, and leaving the app closed for longer periods of time clears out that data? I don't develop, that is likely a completely uneducated suggestion, ignore me if im a dork, hahaha!

Share this post


Link to post
Share on other sites

Thanks for your further explanation, please do let me know how your testing continues.

Using the same iPad as yesterday (having been asleep with the app closed overnight), I launched Designer and my stabiliser settings have not been changed/reset. I then restarted the iPad to see if that would clear the cache and cause the resetting behaviour you're seeing, however I still couldn't replicate this.

I have however found a UI bug in regards to the stroke caps etc which may be causing confusion. If you select the vector brush tool, for example, then set the Cap, join and Align to settings other than default and pin the stroke studio open. Draw a stroke with the vector brush tool, then switch to the move tool and deselect the just drawn stroke. You should see the stroke studio reset to default values as nothing is selected. Now, reselect the vector brush tool and note that the stroke studio does not update and still shows default settings. Don't change any of these settings, simply draw another curve on the canvas. As soon as you release to end the curve, you'll see the stroke studio update and the previously drawn stroke is using the set properties, not the default.

This is a bug we we're not aware of, so I'll get this logged with our developers now :)

However, of all my attempts to reset or change my stabiliser settings on multiple tools, I'm yet unable to replicate this unfortunately. If you do find a recipe to replicate this, please let me know!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×